Community Forum

Not receiving emails.

Highlighted
Frequent Visitor

Not receiving emails.

I'm reposting becaue my last post was banned for showing an email address. I won't do that again.

 

I am not receiving emails from select external (non-Comcast) accounts. Those accounts are not receiving bounce back messages. For example, nothing from southsoundit.com is coming through. How do I determine all of the other emails that haven't reached me?

 

I realize that Comcast is not blocking southsoundit.com.

 

This is what they get on their end:

LOG: MAIN
cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1jBbHt-0003tc-D8
delivering 1jBbHt-0003tc-D8
LOG: MAIN
Sender identification U=southsoundit D=southsoundit.com S=
Connecting to mx1.comcast.net [96.114.157.80]:25 ... connected
SMTP<< 220 resimta-po-22v.sys.comcast.net resimta-po-22v.sys.comcast.net ESMTP server ready
SMTP>> EHLO dedicated4.southsoundit.com
SMTP<< 250-resimta-po-22v.sys.comcast.net hello [198.54.124.178], pleased to meet you
250-HELP
250-SIZE 36700160
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 OK
SMTP>> QUIT
SMTP(close)>>
LOG: MAIN
H=mx1.comcast.net [96.114.157.80]: a TLS session is required, but the server did not offer TLS support
Connecting to mx2.comcast.net [68.87.20.5]:25 ... connected
SMTP<< 220 resimta-ch2-35v.sys.comcast.net resimta-ch2-39v.sys.comcast.net ESMTP server ready
SMTP>> EHLO dedicated4.southsoundit.com
SMTP<< 250-resimta-ch2-35v.sys.comcast.net hello [198.54.124.178], pleased to meet you
250-HELP
250-SIZE 36700160
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 OK
SMTP>> QUIT
SMTP(close)>>
LOG: MAIN
H=mx2.comcast.net [68.87.20.5]: a TLS session is required, but the server did not offer TLS support
LOG: MAIN
== R=dkim_lookuphost T=dkim_remote_smtp defer (-38) H=mx2.comcast.net [68.87.20.5]: a TLS session is required, but the server did not offer TLS support
LOG: MAIN
cwd=/var/spool/exim 8 args: /usr/sbin/exim -v -t -oem -oi -f <> -E1jBbHt-0003tc-D8
LOG: MAIN
<= <> R=1jBbHt-0003tc-D8 U=mailnull P=local S=2960 T="Warning: message 1jBbHt-0003tc-D8 delayed 72 hours"
LOG: MAIN
cwd=/var/spool/exim 4 args: /usr/sbin/exim -v -Mc 1jCvk6-0003O7-OW
delivering 1jCvk6-0003O7-OW
LMTP<< 220 dedicated4.southsoundit.com Dovecot ready.
LMTP>> LHLO dedicated4.southsoundit.com
LMTP<< 250-dedicated4.southsoundit.com
LMTP<< 250-8BITMIME
LMTP<< 250-CHUNKING
LMTP<< 250-ENHANCEDSTATUSCODES
LMTP<< 250-PIPELINING
LMTP<< 250 STARTTLS
LMTP>> MAIL FROM:<>
LMTP<< 250 2.1.0 OK
LMTP>> RCPT TO:<>
LMTP<< 250 2.1.5 OK
LMTP>> DATA
LMTP<< 354 OK
LMTP>> writing message and terminating "."
LMTP<< 250 2.0.0 <> SFCVMV41bF6XMgAAgJX3/w Saved
LMTP>> QUIT
LMTP<< 221 2.0.0 Bye
LOG: MAIN
=> > R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <> SFCVMV41bF6XMgAAgJX3/w Saved"
LOG: MAIN
Completed

 

Email addresses have been removed. They can email thousands of other domains, just not Comcast.
Highlighted
Expert

Re: Not receiving emails.

I just tried to navigate to their web site and got a page saying that they are in Maintenance mode.  Ther service is not available at this time.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Not receiving emails.

Apparently they are rebuilding their website. Their email servers are working fine though. I can reach them via my gmail address and receive their replies. It's only Comcast that's blocking them. What can we do?

Highlighted
Expert

Re: Not receiving emails.


@perfpj wrote:

Apparently they are rebuilding their website. Their email servers are working fine though. I can reach them via my gmail address and receive their replies. It's only Comcast that's blocking them. What can we do?


Try calling Comcast security and see if there is, indeed, a blocking issue for that domain-------------

 

Comcast Customer Security Assurance-------------------

Normal business hours (6:00 am to 2:00 am EST, 7 days a week)

1 - 888-565-4329



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: Not receiving emails.

=> > R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <> SFCVMV41bF6XMgAAgJX3/w Saved"
LOG: MAIN
Completed
 

@perfpj 
SMTP code 250 2.0.0 Message accepted for delivery

Due to there being no recipient i cannot confirm what happened with the email after it was accepted since it wasnt being delivered to anyone. 

I have also reviewed the domain using DNS tools and see that their servers' A records dont match their rDNS records. This may be something that can cause issues with delivering email and in some cases delay email.  The exact exerpt:

Malformed greeting or no A records found matching banner text for following servers, and banner is not an address literal. RFC5321 requires one or the other (should not be a CNAME). If this is not set correctly, some mail platforms will reject or delay mail from you, and can cause hard to diagnose issues with deliverability. Mailserver details:

63.71.12.97 | WARNING: The hostname in the SMTP greeting does not match the reverse DNS (PTR) record for your mail server. This probably won't cause any harm, but may be a technical violation of RFC5321
63.71.12.99 | WARNING: The hostname in the SMTP greeting does not match the reverse DNS (PTR) record for your mail server. This probably won't cause any harm, but may be a technical violation of RFC5321
174.37.177.113 | WARNING: The hostname in the SMTP greeting does not match the reverse DNS (PTR) record for your mail server. This probably won't cause any harm, but may be a technical violation of RFC5321
198.54.124.178 | 250-dedicated4.southsoundit.com Hello dnsstuff.com [74.115.13.4]250-SIZE 52428800250-8BITMIME250-PIPELINING250-AUTH PLAIN LOGIN250-STARTTLS250 HELP

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Not receiving emails.

@ComcastCSAEmail 

Thank you very much for the reply. We've done extensive checking and testing on this domain and it sends and receives fine on all other recipients except Comcast. Recently, they changed the IP address for this domain and rebuilt the PTR, rDNS, DKIM, DMARC, and spf records. The issue persists, all other doamins accept email and Comcast fails.

Highlighted
Official Employee

Re: Not receiving emails.


@perfpj wrote:

@ComcastCSAEmail 

Thank you very much for the reply. We've done extensive checking and testing on this domain and it sends and receives fine on all other recipients except Comcast. Recently, they changed the IP address for this domain and rebuilt the PTR, rDNS, DKIM, DMARC, and spf records. The issue persists, all other doamins accept email and Comcast fails.


So question since you own an email with the domain and have a comcast.net. What happens when you send an email from the domain in question to your comcast.net account? 

Any bounce-back? mailer-daemon? shows sent?

So looking at it from a logical way, if it shows sent on lets say the webmail side of it or in your outlook. Progress. So if it shows sent, but i check our server and i dont see the domain ever even hitting our servers with a "hi, im looking to deliver this email to X@comcast.net" means that even though your end says sent, it actually never left the domains' server. So if it never left the domain and you never got a bounceback or feedback about the email...why didnt you? The logical conclusion would be that something is misconfigured. Do you know if the domain uses any form of exchange server? Does email pass through a spam filter or outlook protection? was the email flagged on the outbound side? Many things could be happening with the domain specifically when sending to comcast.net, but its nothing on the comcast.net end is what im getting at. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Not receiving emails.

Here's what they get:

This message was created automatically by mail delivery software.
A message that you sent has not yet been delivered to one or more of its recipients after more than 24 hours on the queue on dedicated4.southsoundit.com.

The message identifier is: 1jE2SR-0005Rh-AW
The subject of the message is: God I'm sick of this.
The date of the message is: Mon, 16 Mar 2020 19:59:54 -0700

The address to which the message has not yet been delivered is:

p****j@comcast.net

No action is required on your part. Delivery attempts will continue for some time, and this warning may be repeated at intervals if the message remains undelivered. Eventually the mail delivery software will give up, and when that happens, the message will be returned to you.

 

The details.txt shows:

Reporting-MTA: dns; dedicated4.southsoundit.com

Action: delayed
Final-Recipient: rfc822;p****j@comcast.net
Status: 4.0.0

Highlighted
Official Employee

Re: Not receiving emails.


@perfpj wrote:

Here's what they get:

This message was created automatically by mail delivery software.
A message that you sent has not yet been delivered to one or more of its recipients after more than 24 hours on the queue on dedicated4.southsoundit.com.

The message identifier is: 1jE2SR-0005Rh-AW
The subject of the message is: God I'm sick of this.
The date of the message is: Mon, 16 Mar 2020 19:59:54 -0700

The address to which the message has not yet been delivered is:

p****j@comcast.net

No action is required on your part. Delivery attempts will continue for some time, and this warning may be repeated at intervals if the message remains undelivered. Eventually the mail delivery software will give up, and when that happens, the message will be returned to you.

 

The details.txt shows:

Reporting-MTA: dns; dedicated4.southsoundit.com

Action: delayed
Final-Recipient: rfc822;p****j@comcast.net
Status: 4.0.0


the southsoundit.com is holding onto your email and suspending/delaying delivery. This further confirms that there is an issue on the side of southsoundit.com.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Not receiving emails.

That's because: H=mx2.comcast.net [68.87.20.5]: a TLS session is required, but the server did not offer TLS support

 

Is there a particular TLS Cipher they need? Per southsoundit.com this is what they are using: ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384