Community Forum

No POP3 or IMAP services from Comcast in Oregon

Frequent Visitor

No POP3 or IMAP services from Comcast in Oregon

As of about 5/1/2019 my email client (Pegasus) can no longer fetch email off of Comcast's server(s). It is now 5/4/2019 so not a short problem. I also note I can't ping the servers either, from my desktop or (using online web tools) from around the world. I did the switch from non-secure to secure (SSL) last year. I have also done a traceroute and the trace dies in Beaverton OR. I called and talked to Comcast and they say everything is A-Ok. Anyone have any suggestions. I am having to read my email off of Comcast's web client and I want to be able to download the email.

Frequent Visitor

Re: No POP3 or IMAP services from Comcast in Oregon

Oops, checked traceroute again. The traceroute actually got through Beaverton but died in Hillsboro. Interesting, the trace got from Corvallis OR to Seattle WA, before coming back to OR. Maybe it is a Comcast routing error. (Oh I I checked both ipv4 and ipv6. Same answers. )

Gold Problem Solver

Re: No POP3 or IMAP services from Comcast in Oregon

The mail servers often ignore ping and trace packets.

 

What do you get in response to:

    telnet imap.comcast.net 143

I get:

    * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE STARTTLS LOGINDISABLED] Dovecot ready.

(Type "a logout" to exit.)

 

How about the response to:

    telnet mail.comcast.net 110

I get:

    +OK Dovecot ready.

(Type "quit" to exit.)

Frequent Visitor

Re: No POP3 or IMAP services from Comcast in Oregon

Thanks, that is fun I get almost the same

putty (raw) to imap.comcast.net at port 143

* OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE STARTTLS LOGINDISABLED] Dovecot ready.

or

putty (raw) to pop3.comcast.net at port 110 (although port 995 is needed for a secure connection)

+OK Dovecot ready.

______________

But I still can't fetch email off of the server. Smiley Sad

I guess that establishes that it is not a comcast routing issue. Thanks for the hint.

Frequent Visitor

Re: No POP3 or IMAP services from Comcast in Oregon

As an extra, as I look again, it says logins disabled Smiley Sad

Gold Problem Solver

Re: No POP3 or IMAP services from Comcast in Oregon


@foord wrote: As an extra, as I look again, it says logins disabled Smiley Sad

AIUI the server is reporting LOGINDISABLED because the connection is not yet encrypted. The server is essentially telling the client not to attempt a LOGIN until a STARTTLS command has completed. See https://tools.ietf.org/html/rfc2595#section-3.2.

 

FWIW both IMAP and POP are working for me here in Central PA.

Official Employee

Re: No POP3 or IMAP services from Comcast in Oregon

Hello foord, it sounds like you're having issues with your credentials within the 3rd party email client. I can certainly assist you with getting everything updated so that your mail flows through to your 3rd party account. For further assistance please send me a private message with your full name by clicking on my name (ComcastAmir) and then click "Send a message" for further assistance. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: No POP3 or IMAP services from Comcast in Oregon

More data on my problem (no answers). When I try to get my pop3 mail my email can creat a log. The log shows

Connect to 'pop3.comcast.net' port 995, timeout 30.
18:15:35.453 [*] Connection established to 96.116.224.178
18:15:35.500 22: Error -32 activating SSL session (locus 6014, type 4, 'Bad server key agreement parameter signature\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC\FFFFFFCC')
18:15:35.500 --- Connection closed normally at Wed, 15 May 2019 18:15:35. ---\0A\0A

 

So I wonder if Comcast updated some software. I didn't for this application. 

Official Employee

Re: No POP3 or IMAP services from Comcast in Oregon

Hi foord, thank you for providing this information here. I replied to your PM, please reach back out to me there for further assistance. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: No POP3 or IMAP services from Comcast in Oregon

Hi foord, it has been great speaking with you. I am glad that we were able to talk a bit more about this and provide some steps that may have helped you resolved your issue. Feel free to reach back out to me here or via private message if you need anything else, have a good day. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!