Community Forum

Missing Emails

Regular Contributor

Missing Emails

This morning I noticed that I'm missing emails from the past couple of days that should be in my Inbox. I know I didn't delete them.  But even if I did, they would be in my Trash - which they're not. This is happening on the webmail as well as my Android Connect app.

 

I sent myself an email as a test this morning, and I did receive it.

 

Anyone else having this issue?

Regular Contributor

Re: Missing Emails

Update: The last email showing in my Inbox is from last Thursday, 8/8/19.

 

Help!

Expert

Re: Missing Emails


@g-hodgson wrote:

This morning I noticed that I'm missing emails from the past couple of days that should be in my Inbox. I know I didn't delete them.  But even if I did, they would be in my Trash - which they're not. This is happening on the webmail as well as my Android Connect app.

 

I sent myself an email as a test this morning, and I did receive it.

 

Anyone else having this issue?


Do you have the account enabled on another computer/device using a desktop client or app set up with POP3?  If so, it may be downloading the messages and then deleting them from the server.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Contributor

Re: Missing Emails

No, I do not. For years, I've used only the Xfinity webmail directly (no Outlook, etc.). And I use the Connect app on my phone.

I've had this happen more than once over the last year or so. Emails are there, then they aren't. Then at some point, usually within the same day, they reappear.

Frustrating.