Community Forum

Marking email "Not Spam" is broken

Highlighted
Frequent Visitor

Marking email "Not Spam" is broken

I discovered my work email was suddenly marked spam, and held in a spam folder on the website.  I usually receive my email through Outlook.  I marked it as not spam yesterday and was able to download it through outlook as usual.

 

Today, it again marked my work email as spam, but this time, when I right clicked and marked as "NOT SPAM", it went to the inbox folder, and then immediately back to the spam folder.  The only way I can insure i get my work email is to turn off spam blocking completely.

 

I don't know what happened just this week to cause this behavior.  I've been receiving email from the same workplace for over 6 years!  It is crazy inconvenient for me to login to the website everytime I want my work email.  Please fix this!

Highlighted
Expert

Re: Marking email "Not Spam" is broken

Can you clarify--------if you use only the webmail UI and your  browser to access the account instead of Outlook, does the same thing happen?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Marking email "Not Spam" is broken

I was on the webmail UI on my browser when I saw it happen.  I right clicked the email, marked it as not junk, it went to my inbox, and then immediately back to the spam folder.

 

Thankfully with the security turned off all my mail is being delivered to Outlook now.  But honestly, I should be able to use the spam filter, marking items as not spam, and having it stay that way.

 

A whitelist is too restrictive.

Highlighted
Expert

Re: Marking email "Not Spam" is broken


@Somebunni wrote:

I was on the webmail UI on my browser when I saw it happen.  I right clicked the email, marked it as not junk, it went to my inbox, and then immediately back to the spam folder.

 

Thankfully with the security turned off all my mail is being delivered to Outlook now.  But honestly, I should be able to use the spam filter, marking items as not spam, and having it stay that way.

 

A whitelist is too restrictive.


The Comcast email software has no whitelist function.  As a check, disable the account in Outlook and then try the webmail UI again.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Marking email "Not Spam" is broken

It is called "Email Safe List" and is the first option in Advanced settings.  It's a whitelist no matter what it's called.

 

I don't know what disabling the account in Outlook 365 would do? 

 

This occurred on the webmail site.  If I go to the spam folder on the webmail site, right click and mark a work email with an attachment as "not spam" it moves to the inbox, then immediately back to the spam folder. 

 

I discovered this becasue suddenly on Monday I had no work email, which was odd.  I confrimed with my employer it was sent.  I've never had it marked as spam on the web ui before.  I checked just to be sure, and lo and behold, there was all my work email sitting in a spam folder.  First time in 6 years it's happened.

 

So, something changed.  I don't know what changed, but the only way "I" can fix this and stay employed is to shut off the spam filter.  This should Not be necessary.  Right?

 

Highlighted
Expert

Re: Marking email "Not Spam" is broken


@Somebunni wrote:

It is called "Email Safe List" and is the first option in Advanced settings.  It's a whitelist no matter what it's called................................

 

 

 


No, it's not a whitelist.  The "Safe List" in the Comcast email software serves a different purpose.  When you enable that feature, only emails from senders you deliberately put on that list will get  to the Inbox.  Nothing else will get through.   It will block incoming email from anyone except the senders on that list.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Marking email "Not Spam" is broken

That is literally the definition of a whitelist.

Highlighted
Expert

Re: Marking email "Not Spam" is broken


@Somebunni wrote:

That is literally the definition of a whitelist.


No it's not.  A real whitelist allows all usual emails to get to the Inbox.  The whitelist is  for  legitimate senders that keep getting dumped into the Spam/Junk folder.  See here--------------

 

https://whatis.techtarget.com/definition/whitelist

 

So unless you want your account limited to getting emails from whoever you put on the Safe list, you would need to disable it.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Marking email "Not Spam" is broken

NONE of this is fixing the problem.  The issue is this:  Marking email as not spam in the spam folder, does not work as intended.  Instead it moves the mail to the inbox folder, and returns it to the spam folder.

 

 

Highlighted
Expert

Re: Marking email "Not Spam" is broken

I've noticed some issues recently with the spam folder too. Currently I'm trying to keep track of what's working and what's not working correctly so I can list them to report.

 

@Somebunni 

Instead of right clicking on an email in the spam folder, check the box in the left column instead. Click the not spam icon on the toolbar, and see if that correctly moves the email to the inbox.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Marking email "Not Spam" is broken

I did try that as well when I was struggling with it and the email still popped back into the spam folder. 

 

I can mark an email as spam myself, let it move to the spam folder, and then unmark it as spam in the spam folder and it works as it should.  I've tried it with both the spam filter on and off just now.

 

However, the emails that were sent to the spam folder included attachments, I'm not sure if that made a difference.  I'm just going to leave the spam filter off.  These emails are too important to just disappear, and already I'm finding out from work that I'm missing stuff.  I don't know how long this has been going on.