Community Forum

Error The connection to remote server imap.email.comcast.net was refused or timed out while attempti

Contributor

Error The connection to remote server imap.email.comcast.net was refused or timed out while attempti

I've been getting the message below all day. What's going on? Never had the problem before.  I've been using Xfinnity for my emails and messages. So how to fix?

Error

The connection to remote server imap.email.comcast.net was refused or timed out while attempting to connect. Please try again later.
New Poster

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

What OS?

What mail application?

When did this problem start?

Contributor

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

Windows 10.

Xfinity online email site.

Trying to read email. trying to delete email (?) on Xfinity..

Funny, it seems to have straightened out for now. But why did this happen in the first place? I keep getting messages that comcast email is out of date. Yet, I don't use the comcast email. I read and delete them on the Xfinity website.

Frequent Visitor

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte


@abbypatch wrote:

Windows 10.

Xfinity online email site.

Trying to read email. trying to delete email (?) on Xfinity..

Funny, it seems to have straightened out for now. But why did this happen in the first place? I keep getting messages that comcast email is out of date. Yet, I don't use the comcast email. I read and delete them on the Xfinity website.


I've been having a related problem. Midday today I stopped being able to access my IMAP mail on Comcast via Thunderbird and Claws Mail on Linux. But!... I *am* still able to get to it on my Windows machines and on my Android phone! I kept getting "Cannot connect" and "connection refused" error messages. I eventually got a hint to change the IMAP server name from imap.comcast.net to imap.ge.xfinity.com -- and it now works. This has not been necessary on any of my other devices, just the Linux one.

 

Can anyone suggest why only the Linux machine is having trouble, and not the Windows or Android ones? I'm going to keep an eye on this - I have a feeling I'm going to have to change it back to imap.comcast.net before long.

Frequent Visitor

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

[Me too] Thunderbird 60.2.1 on Ubuntu 18.04 "Failed to connect to server imap.comast.net"
New Poster

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

ubuntuforums.org/showthread.php?t=2406399

See #23

Frequent Visitor

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte


@RedVan wrote:

ubuntuforums.org/showthread.php?t=2406399

See #23


Thanks for the pointer. That explains it pretty well. It's odd that the bug didn't hit me until now, although maybe it was something in a recent Mint update. I'm sure it will be fixed soon and the workarounds are acceptible for now.

Frequent Visitor

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

For those looking for a more direct answer, name resolution for imap.comcast.net seems to be failing recently. Users in the Ubuntu forum thread offer the resolution of changing the account's server to one of the IP addresses reported by "nslookup imap.comcast.net" (use the terminal, Luke.) Rather than using a fixed IP address, I reset the server name to imap.ge.xfinity.com (the canonical name for imap.comcast.net) then had to submit my password for the newly-named server. Works a treat.
New Poster

Re: Error The connection to remote server imap.email.comcast.net was refused or timed out while atte

I've found there's a little more to this...

It appears this is also related to IPv6.  I happen to be using Ubuntu 18.04.  If you're using another operating system, this may also apply to you.

 

The output from the nslookup command presented me with major clue.  The address in the output was IPv6.  The reason this surprised me was that, I had disabled IPv6 via the network applet in Gnome's GUI system settings.   In addition, I thought I was blocking IPv6 at my firewall's WAN interface.  ifconfig at the terminal prompt revealed I had a dynamically assigned IPv6 address.

 

Upon some research, I've found a bug exists in my version of Ubuntu,  disabling IPv6 in any of  several system files where it can be disabled doesn't actually disable it, but modifying /etc/default/grub will work.  This still didn't explain why an IPv6 address name resolution was able to traverse my firewall.  I checked my firewall's WAN filter and found that I had actually allowed versions 4 & 6 in the rules.  

 

In a nutshell, I think even though portions of the auto configuration (some server settings and smtp) where acquired, the imap server address was actually being resolved with IPv6 somehow prioritized over IPv4(?).  Upon modifying the /etc/default/grub file is described in this discussion: https://askubuntu.com/questions/1046057/disabling-ipv6-in-ubuntu-18-04, I was able to block IPv6 and its name resoluntion.  Once I did this, updated grub and rebooted, ifconfig no longer displayed a dynamically assigned IPv6 address.  I then opened Thunderbired, modified the IMAP account settings, entering Comcast's published imap.comcast.net server address and guess what?  It worked.

 

In summary... If you're using IPv6 and trying to connect to imap.comcast.net and experiencing connection problems, you can either disable IPv6 use "imap.comcast.net" or change the server address to "imap.ge-xfinity.com".  Not certain, but Thunderbird appears to beprioritizing IPv6 name resolution is prioritized over IPv4.  In addition, Comcast doesn't appear to be aware of this and hasn't published the imap.ge-xfinity.com server address.  Something has changed there at comcast  and not every network admin/engineer may be aware; because the IPv4 & IPv6 host names and addresses are not synched to the host(s).  It took an Ubuntu bug and the orginal post in this thread  for me to derive this. ugh!