Community Forum

Email Shows Sent but It Is Not Received By Those I Send Them To

Highlighted
Regular Visitor

Email Shows Sent but It Is Not Received By Those I Send Them To

I twice have sent an email to 3 different recipients who do not use Comcast and they never got the email and it shows as sent for me and does not bounce. I have also noticed that it takes a long time for emails to send once I press SEND. I did a test and was able to send to myself at my office. It is not in the recipients' spam folders. Ideas?

Highlighted
Official Employee

Re: Email Shows Sent but It Is Not Received By Those I Send Them To

@tucsonhd can you please PM me the specifics and i can take a further look into this for you.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Email Shows Sent but It Is Not Received By Those I Send Them To

Sure. How do I do so?

Highlighted
Expert

Re: Email Shows Sent but It Is Not Received By Those I Send Them To


@tucsonhd wrote:

Sure. How do I do so?


Click on @ComcastCSAEmail's name in their post and then on Send message.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!