Community Forum

Change in POP3 port from 110 to 995

New Poster

Change in POP3 port from 110 to 995

I changed my POP3 port from 110 to 995 and now i can no longer connect to Xfinity mail.   It times out when trying to connect.  I am using Windows live mail 2011.

Expert

Re: Change in POP3 port from 110 to 995


@dt43 wrote:

I changed my POP3 port from 110 to 995 and now i can no longer connect to Xfinity mail.   It times out when trying to connect.  I am using Windows live mail 2011.


Have you tried going back to port 110 for now.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Change in POP3 port from 110 to 995

I checked the SSL box and the 995 port connected.

Expert

Re: Change in POP3 port from 110 to 995


@dt43 wrote:

I checked the SSL box and the 995 port connected.


Good news!


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Contributor

Re: Change in POP3 port from 110 to 995

Would be much better if they updated the certificate so Outlook would not error. Likely too much to expect.

New Poster

Re: Change in POP3 port from 110 to 995

I have the same issue.  I am


@dt43 wrote:

I changed my POP3 port from 110 to 995 and now i can no longer connect to Xfinity mail.   It times out when trying to connect.  I am using Windows live mail 2011.



I am using Outlook 2013.  Comcast customer service is (so far) clueless after 40+ minutes.  This is ridiculous

New Poster

Re: Change in POP3 port from 110 to 995

Second level comcast support solved the issue for me

New Poster

Re: Change in POP3 port from 110 to 995

I too cannot successfully change to Port 995. I have chatted with support twice and they have elevated me to 2nd level support, but 2nd level support has not contacted me yet. It's been 14 days!