Community Forum

Slow Internet after Xfinity Home install

New Poster

Slow Internet after Xfinity Home install

I recently upgraded to 450Mbps Internet speeds and at the same time added Xfinity Home Security. Prior to the Xfinity Home install I had 450Mbps download speeds. Yesterday the Xfinity tech installed the security system which required an Xfinity Home Security Router that he said must be connected directly to my cable modem (I own the cable modem and my home wifi router). Now the Internet speeds are stuck at about 100Mbps. Suspecting the Xfinity Home Security Router, I looked and confirmed it is a 10/100Mbps router. 

 

Can someon confirm that having this Xfinity Home Security Router connected directly to the cable modem is a requirement? Seems silly since it prohibits you from achieving the Internet speeds you pay for. I tried to connect my WiFi router directly to my Cable Modem and it didn't work anymore. If this is a requirement, I will cancel my Xfinity Home Security service before the 30 day period. 

 

Thanks,

 

Brian

Highlighted
Diamond Problem Solver

Re: Slow Internet after Xfinity Home install

Is your personal router after the security router?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: Slow Internet after Xfinity Home install

It is. The tech told me it must be that way.

Diamond Problem Solver

Re: Slow Internet after Xfinity Home install

It doesn’t matter, that security router will never give your personal router more than 100 mbps. Just reverse the two

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Silver Problem Solver

Re: Slow Internet after Xfinity Home install

To add, don't forget you will have to powercycle the modem when changing the device directly connected to it to get a connection.

New Poster

Re: Slow Internet after Xfinity Home install

After placing the Xfinity Home Security Router after my home router internet works great and now has the 450Mbps, but Xfinity Home cannot connect. Any other thoughts? Is it possible the installer configured the Xfinity Home Security Router in a way it must be installed right after the cable modem?

New Poster

Re: Slow Internet after Xfinity Home install

I celebrated too soon. While WiFi works great, Xfinity Home cannot connect. 

Diamond Problem Solver

Re: Slow Internet after Xfinity Home install

There isn’t anything to configure on the router. Is there possibly a setting on your personal router that the 2 aren’t communicating?
https://www.xfinity.com/support/articles/connect-xh-router

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: Slow Internet after Xfinity Home install

Not that I'm aware of. This is a brand new home router and everything else I've connected to it works fine. I also went into my home router app and ensured none of the ethernet connections were paused.

New Poster

Re: Slow Internet after Xfinity Home install

A Comcast employee helped me last night identify that I may have a bad port on my new home WiFi router. After switching to another everything works. Thank you all for your help!!