Community Forum

Xfinity Internet stops working asks me to reactivate my service once every month

New Poster

Xfinity Internet stops working asks me to reactivate my service once every month

Hello,

 

Xfinity keeps asking me to reactivate my internet service once every month. It also keeps charging me for the modem which I own and every time this happens, I had to contact the customer support to remove the device (as it my own) and adjust the bill.

 

Its really annoying to keep repeating this process every month. Any idea why this might be happening? 

 

I guess is that there could be some problem with the provisioning of my modem.

 

Note: This started happening since the day  I signed up for a new annual contract after my old one expired.

 

Really appreciate any help in this regard.

New Poster

Re: Xfinity Internet stops working asks me to reactivate my service once every month

I have this same problem have you had any lick with this?

New Poster

Re: Xfinity Internet stops working asks me to reactivate my service once every month

Good to know that I'm not alone. But sorry, no help or suggestion from anyone so far.

Too bad Im stuck with this. This repeated again this month and I had to repeat the same process (contact support->explain them the problem->Support checks the account->Support confirms that the problem is on their end->Support removes the inactive device and adjusts the bill->Support assures that this will not happen again as the inactive modem has been removed->End of support and pay the new adjusted amount   --> And Im sure this will repeat next month).