Community Forum

Waiting for cable to be buried after installation over a month ago!

New Poster

Waiting for cable to be buried after installation over a month ago!

Can anyone advise how long it typically takes for Xfinity to bury the cable after installation.  I had new service installaed at my home a month ago and after repeated calls and chats there is still an orange cable in my yard not buried.

 

Any assistance would be greatly appreciated! 

Highlighted
Official Employee

Re: Waiting for cable to be buried after installation over a month ago!

Hi nicke12. We welcome you to the Xfinity Forums and thank you for creating your first post. I can assist with alerting our local Tech Ops team to bury the cable drop in your yard. To get started, please send me a private message and include your full name so I can assist you. You can click my name (ComcastJoeTru) to view my profile and send me a private message. Click "Send a private message" and private message me.
 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Waiting for cable to be buried after installation over a month ago!

Hi nicke12. I did not receive a private message from you. This thread is now locked. Please don't hesitate to send a private message if you continue to need help with this, or create a new post if you need assistance with anything else. Thank you.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!