Community Forum

Utility Boxes With Missing Lids

Highlighted
New Poster

Utility Boxes With Missing Lids

I have tried every which way I can think of to get someone out to my property to repair these utility boxes. We have exposed wires all over the place and I cannot get anyone to take it seriously. I don't know if they just don't care or if they have absolutely zero communication between departments or if it really does take 6-8 months to get something as simple as a utility box lid. I need help. If someone employeed with Comcast is reading this, please help me. I don't mean to be a horrible pain, I just want my residents safe.

Highlighted
Official Employee

Re: Utility Boxes With Missing Lids

Greetings, @meganrchmnd! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day! I apologize to hear of the issues you have been having with trying to get the utility box replaced. I would like to have a look into this and see if we can get that fixed for you. Can you please send me a PM with your first and last name so I may further assist you?

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!