Community Forum

Incompatible Modem?

Frequent Visitor

Incompatible Modem?

After having some recent speed issues with my supposed 150MBPS connection and getting an average of about 12MBPS across multiple speed testing sites I went to the My Account app and come to find out the modem I was given and I assume am paying a monthly rental fee for, the ARRIS SB6121, is incompatible with my service. It then directed me to a compatible one that costs almost $200 on Amazon. I pay almost $200 for my cable so I would expect the equipment I was given to be compatible with my service and would appreciate someone contacting me about a replacement. Thanks.
Screenshot_20180729-223939.png
Expert

Re: Incompatible Modem?

@Melancholy43952

 

Go here https://customer.xfinity.com/#/equipmentupdate to upgrade your rented equipment. You can also swap your equipment @ your local service center. 

 

https://www.xfinity.com/support/service-center-locations/


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Frequent Visitor

Re: Incompatible Modem?

All of our local service centers closed down. I'm gonna need a compatible modem shipped out so I can return this one. That link only lets me return cable boxes.

Frequent Visitor

Re: Incompatible Modem?

I am the primary user...

Screenshot_20180730-203443.png
Official Employee

Re: Incompatible Modem?


@Melancholy43952 wrote:

I am the primary user...


You may be the primary user but if you're using the same username above that you logged into the forums with, you're using a secondary e-mail address.

 

Your modem looks like it's your own, you can get one of ours for an additional rental fee or replace it on your own.

Frequent Visitor

Re: Incompatible Modem?

This modem was given to us by Comcast when we signed up for Internet years ago. I never purchased a modem, only the router.

Frequent Visitor

Re: Incompatible Modem?

I went ahead and bought an ARRIS SURFboard SB6190, which is listed as compatible. I have the Performance Pro tier up to 150Mbps plan but am still showing the same slow performance. Of course Xfinity shows a faster speed but still well below 150Mbps. If it helps I'm using a Belkin N300 router model F9K1002V4.

Screenshot_20180802-133947.png
Screenshot_20180802-134037.png