Community Forum

Comcast saying some of my devices need to be updated...

Regular Visitor

Comcast saying some of my devices need to be updated...

Under "Devices" in my online account, the following is displayed: "Some of Your Equipment Is out of date. Old equipment can affect your service. Update now to enjoy the latest features. Get your update." However, when I click on the link "Get your update" (https://customer.xfinity.com/#/equipmentupdate), whether I stay on the page or open a new page, that page never opens. I let it "spin" for over 10 minutes and it didn't even time out, just kept on rotating 3 dots horizontally on a blue screen that has "xfinity" at the top of the page. Why won't this page open? How can I find out which of my devices is "out of date?" Then, what do I need to do to get the affected device(s) updated? Will updating my devices be free or cost something? Thanks for your help.

Expert

Re: Comcast saying some of my devices need to be updated...

I've asked a Comcast employee to help you. You should expect a reply in this thread. 


I am not a Comcast employee, just a moderator. Pls observe Wheaton's Law.
Official Employee

Re: Comcast saying some of my devices need to be updated...

Hi listwhfx. I can assist with reviewing your account for the old equipment and the online error you're encountering. Please send me a private message and include your full name and account primary phone number so I can access your equipment.

Regular Visitor

Re: Comcast saying some of my devices need to be updated...

Thank you ComcastJoeTru for your response and offer of assistance. How do I send you a private message? When I place my mouse pointer on your name and then click on "Send Message" in the box that pops up, another page opens up indicating at the bottom of the screen "Xfinity Help & Support Forum / Private Messages" and underneath that "Private Messages". Below that is a white area which seems to be where I should be able to send a private message to you, but it doesn't allow me to do that (see attached pic). At the top of the screen is the "Welcome to Xfinity Help & Support Forums," "Find solutions, share knowledge, and get answers from customers and experts New to the Community? Start here." Below that is the box in which to ask a question of the community, where I could enter something, but that would just go back to the general forum. So, I'm at a loss at how to send you a private message so you can check out the equipment I have. Please let me know what I need to do. Thanks.
P.S.: Thank you nerdburg Cable Expert for passing along my problem to ComcastJoeTru.

Private Message Screen.jpg
Official Employee

Re: Comcast saying some of my devices need to be updated...

 

listwhfx, I'm following up for Joe while he's out of the office. I'll try to send you a test private message to see if you get it.