Community Forum

Been paying for Blast! Pro since 9/2016 but no modem upgrade = no speed. Thanks, Xfinity.

New Poster

Been paying for Blast! Pro since 9/2016 but no modem upgrade = no speed. Thanks, Xfinity.

I've been an Xfinity customer since 2013.  I signed on with the Triple Play package but decided in September of 2016 it was finally time to cut the stuff we never used.  Stuck with Xfinity for internet and tacked on Blast! to up the speed to 250Mbps for an additional $30/month.

 

What Xfinity failed to mention was the TC8305C modem I had (spec'd at 150Mbps) could not handle the speed and that I needed a new one.  Call me naieve, but in nearly 1.5 years I never thought to do a speed test to verify I was getting what I was paying for.  Only recently as I've added a few more devices to the nextwork did I decide to take a closer look.

 

Opened up a chat on 5/28 during which I was informed by the rep that my modem was the reason I couldn't get 250Mbps (not even close). A new one is on the way (TG1682G) and I was given a partial credit for the current bill.  I was told further adjustments would be handled by Billing.  Overall, an efficient and positive experience!

 

I decided today to follow-up regarding the adjustments (read "what will Xfinity do regarding the $600 of invalid charges I paid from 9/2016 through 4/2018).  Chatted with a rep for nearly an hour.  It started out well enough (was offered 3 mos credit for Feb-Apr as well as credit for next month Jun and a promotion that would save me $20/mo for the next 12 mos).  I was willing to agree to this arrangement even though it only meant I would recoup part of the invalid charges (4 mos credit at $30/mo plus $240 savings = $360).  I was OK with checking back in 12 mos for the rest.  THEN, the rep reneged and said he could only offer $50 in credits (second offer was $60) and the new contract.  Being that this was not the agreement we had JUST delineated, I said no thanks and decided to escalate the issue.

 

Got on the phone with a rep and eventually someone I believe was her supervisor (I love call centers).  The supervisor proceeded to tell me I had been "misinformed" and that my existing modem could in-fact handle the speed (this is false).  She offered $10 for the bad experience.  At this point Xfinity reps had lied to me at least twice.  Growing increasingly frustrated, but willing to let her try again to make it right, I waited while she looked for the "best" promotion she could offer.  Lo and behold, she could cut me a deal for the addition of streaming services and save me $4!  Thank you, but LOL.

 

My new modem is due to arrive tomorrow.  I think I'll take up this issue in-person when I go an Xfinity store to return the old one.

 

Any thoughts/suggestions regarding this issue are welcome.

 

 

Official Employee

Re: Been paying for Blast! Pro since 9/2016 but no modem upgrade = no speed. Thanks, Xfinity.

Hi @rgandsteph

 

I'd like to help address your billing concerns. Please send me a private message by clicking on my name, "ComcastChe" then click private message me. In the body of this message please verify your first and last name, street address including city state and zip code, and the account number or phone number associated with your services.