Community Forum

new-not modem

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

new-not modem

Greetings. I'd appreciate a way to resolve this issue, if you know of any. Repeated chat/phone/local-office help has not helped.

I bought a brand new (I thought) cable modem back in 2016 from Amazon. I connected it easily, but when trying to register it to my account, I found it "already registered by another user", so my account continued to list my previous modem as device. This problem ("already registered") is anything but new, as I found out online, I'm just the latest "affected customer" (keeping it polite).

 

I kept the modem, because it worked, and forgot about the device registration, until now: the previous modem has gone unsupported, and I received numerous warnings (letters, emails) that my connection "will be interrupted". I managed to find out that the system that "sees" the physical device "does not talk" to the system that keeps the account registration and sends the warnings. Actually, if I understood correctly, I should not even be getting warnings, since those apply only to customers leasing equipment from Comcast (or Xfinity, whichever it is).

 

So, my physical modem is supported, and now working slow as turtle (laughing opportunity), but I am still online while I am locked out of my Xfinity account. I'm not going back for another useless help session (nicest people! they just don't have the tools). If anyone here knows of an administrative solution, please post. I'm not eagerly going out to buy another new-not modem. Thank you.