Community Forum

being charged, without service

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

being charged, without service

I've been trying, to get my cable and internet services set up, since May, 2017. I ordered the services, online, without installation. However, the modem never worked. The third light never went out, meaning, there was no signal. The cable boxes I received, were incompatible, with my TV'S. I called customer service, around March. The representative told me, to take the equipment to a Comcast center, for exchange. The Fremont location has been closed, for some time. I asked, for a closer location. The representative told me, there was one in Fremont. However, the street address, he gave me, was for San Jose. I was so frustrated, I gave up, trying, until recently. I found out, there is a Comcast center in Union City. The representative, there, was very nice. She said, the boxes I had weren't for HD TV's. She exchanged, all of the equipment. I asked, for all of the coax, HDMI, and power cables. The representative told me, to contact billing, about having been charged, about $60 a month, since May. Clearly, I wasn't able to get service, with the devices I had. She also informed me, the original representative should have offered to send a technician, to do the install, for free, since I was having issues. That was news, to me! I left, and took the new equipment home. However, when I tried to set up the new equipment, I realized, the power cords, and 2 coax cables were missing. So frustrated! Help!
Expert

Re: being charged, without service

Your issue has been escalated to the Comcast Team available to the Forums. A member of that team will reply to your post as quickly as they are able, so check back often.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: being charged, without service

Hi bg247,

 

Sorry for the experience you've had while trying to get your services activated. I'd like to review your account to see how I can make this right and see about getting the cables you need. In order assist you, please send me a private message verifying your first and last name, the phone number, street address, and the account number associated with your services.

 

To send a private message click on my name "ComcastChe", then click private message me.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!