Community Forum

Unable to use Xfinity.com Web Portal

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Unable to use Xfinity.com Web Portal

Update: it seems this is because my account is new and not yet "completely activated". I was able to use the support Chat feature as Guest to avoid having to sign in, and a customer service representative confirmed this for me.

 

I tried from Google Chrome and Mozilla Firefox, no addons enabled.

I'm getting this error when I log in:

Screen Shot 2018-06-28 at 8.19.40 PM.png

 

Then it kinda gives me profile options except the nav menu is named "true".

Screen Shot 2018-06-28 at 8.19.09 PM.png

 

 

Anything else I try to do doesn't load the page, for example when I try to go to Account Settings or View My Bill, I will see the spinner loading forever. 

 

Official Employee

Re: Unable to use Xfinity.com Web Portal

Hi @statueofmike

 

That's correct. I'm happy you were able to get this confirmed. If there;s anything we can help with in the future, please don't hesitate to reach out. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!