Community Forum

Tech didn't return equipment ???

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Tech didn't return equipment ???

I moved from one location to another.  I called to set up moving services and Comcast told me to bring my old equipment with me.  The tech came to set up my service at my new location about 12 days ago.  He replaced my modem and I also got rid of cable.  The tech took my old equipment with him and now I am getting calls from what I assume is a third party saying that my old equipment was NOT returned.  I gave it to a comcast representative and THEY have it.  I refuse to continue to be harassed on the phone.  I called customer service earlier and they said they'd "take care of it" although upon reading more posts on here & reddit I am not confident at all.  I'm still within my 30 day guarantee and will cancel my service if this is not resolved before then.

Admin1

Re: Tech didn't return equipment ???

Hi kfred622 -- I can help with this equipment issue. Please send me a PM with your name, full service address, and either phone or account number. I will also need your account information from the account the old equipment came from. I'll be able to get this equipment removed for you.

 

Click my name (ComcastZach) and click Private Message Me. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!