Community Forum

Re: xFi Pods Speed

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Re: xFi Pods Speed

Same issue here. I bought the 3 pack of pods and distributed them throughout the house. The app said they were good or great but anything gaming or video connected to them has lag or buffering issues. Less issues without them. I tried moving them around but nothing changes. Probably should of went with a 3rd party but I like the xFi app features.
Official Employee

Re: xFi Pods Speed

 

EdBR, thanks for posting here. I'd like to check your connection to make sure there aren't signal issues at play affecting your speeds on the xFi Pods. 

 

Please send me a private message with your full name and phone number tied to your residential services for help.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: xFi Pods Speed

 

EdBR, glad we were able to address the signal issues at the modem that contributing to the issues you saw with the xFi pods. Post again if you need further assistance. 

 

KenF


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!