Community Forum

Re: XRE-03007 Worst Experience Ever

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Highlighted
Regular Visitor

Re: XRE-03007 Worst Experience Ever

In August my payment was applied to a wrong account. I have spent hours & hours on the phone with Comcast reps from around the world. I had to fax bank statements to the big south region showing the payment had cleared. It took Comcast 6 weeks to locate the payment & I continued to pay my bill. In September, I went without service for approximately 2-3 weeks. My October bill showed that I had $145+ in reconnect fees while they were looking for the misapplied payment. I continued to wait on hold (and continued to pay my bill), and finally was informed through a live chat that my the reconnect t fees exceeded the allowed by COMCAST and my account and I would receive a pro-rated credit for the days without service.
I tried to pay my bill, through the app & online, and couldn't. I took cash to the payment center, 30 miles away because I had been shut off again.
They restored my service, said credits would be applied to next months bill.
Saturday, I received a message from a rep, tried to call her back, spent another 1:52 hours on the phone with someone in Asia & learned, after being assured numerous times my account would be credited, that it was denied & my bill was now over $800 (because of all the additional reconnect fees) and if I didn't pay it by November 22, service would be disconnected again!
Of course, it's off! Im taking all of the equipment to the store tomorrow & filing a complaint with the public utilities commision! Thank goodness I have, in writing, all of Comcast's empty promises!