Community Forum

Plant extension seems to be stalled

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Visitor

Plant extension seems to be stalled

Back in January I paid for a plant extension to get Comcast up and running at our new (to us) house. After some back and forth the cable was run on the poles and then a big run was burried in the ground but I am still waiting for them to connect everything up. For the past few weeks I've tried calling the contact and he hasnt returned my called, worried that he moved on and now I don't have any good contact.

 

Wondering if someone can help look into my case (I have a reference job number)? Everytime I have tried calling the 1800COMCAST I think i've made things worse so don't want to do that again.

 

Thanks!

Official Employee

Re: Plant extension seems to be stalled

 

Stattico, I'll look into your plant extension. Please send me a private message with your full name, address, and phone number tied to your residential services for help. Just click my name and then click private message me.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!