Community Forum

Having trouble registering my cable set up. Am adding cable to an account I already had

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Having trouble registering my cable set up. Am adding cable to an account I already had

Am  adding cable to an account I have but cannot get it registered

Expert

Re: Having trouble registering my cable set up. Am adding cable to an account I already had

I have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread from a Comcast Official Employee.



I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!
Official Employee

Re: Having trouble registering my cable set up. Am adding cable to an account I already had

 

Hi franc2, I can assist you with activating your equipment and getting your cable service up and running. Can you please send me a private message with your full name, street address, and account number by clicking on my name (ComcastAmir) and then "private message me"?

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark the post as best answer!