Community Forum

Fake Inactive EMTA

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Fake Inactive EMTA

Since the start of 2018, around when Comcast Xfinity gave the free speed boost, I have been charged $10 for an inactive emta each month.  But I have never rented a modem from Comcast.  I always buy my own.  I called customer support, they told me I had to go to an Xfinity store.  I went to an Xfinity store with the letter I had received about the "modem" I am supposedly not returning, which included its "serial number," and they told me the charge would be taken off my bill.  It looks like the fictitious device is gone from my account but I am still getting the inactive emta charge on my latest bill.

 

I still have the documentation from the technician who set up the two devices I actually do have, but I cannot prove that I don't have a device that never existed.  Comcast did the same thing to my brother when he was a customer, he also always buys his own modem.  I hope someone with customer service will actually respond to do something about this. I am very upset that Comcast Xfinity is running this apparent scam, and if I do not get restitution quickly, I will end my Xfinity service when my current contract ends in June.