Community Forum

Comcast claims my owned modem is thiers.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Comcast claims my owned modem is thiers.

I bought my modem over a year ago to avoid the rental fee.  It was set up and everything was good then after a year they now claim the modem is theirs.  I have the receipt and explained it to the representative but they wouldn't listen me, very rude.  I see from this forum it is a common issue for Comcast to start charging rental fees out of the blue and claim the equipment belongs to them.  I have my bills with no rental fee are they just trying to see if I notice the fee has been added.
Very exasperated.

New Poster

Re: Comcast claims my owned modem is thiers.

Is anyone from Comcast going to take this seriously.  I need this resloved!  I see others have the same problem and their getting results and I'm getting angry!

Regular Visitor

Re: Comcast claims my owned modem is thiers.

I don't know if you ever got this problem resolved, but I going through the same thing, with a modem I've bought in 2009!  Afraid I don't have any helpful hints as my issue also remains unresolved.  But, you are not alone.

 

http://forums.xfinity.com/t5/Customer-Service/COMCAST-claims-customer-owned-modem-is-a-rental/m-p/30...