Community Forum

Charged $10 monthly for 4 years for Inactive eMTA equipment I returned.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Charged $10 monthly for 4 years for Inactive eMTA equipment I returned.

Hello,

 

I have been charged for the last 4 years for $10 a month for Inactive eMTA fee. I returned this device, but I have been told on numerous occassions Comcast has no record of it, or it will be taken off my bill, which has never happened. 

 

Please take this off my bill somehow. Surely I have paid for the cost of the device x10 in the last 4 years at $120 a year, even if I had not returned it, which I most certainly did. I walked into the Comcast store here in Spokane myself and placed it in a return recepticle. There is no reciept given by the recepticle so unless we can dig up 4 year old video of me doing so, I guess I can't prove it, but haven't I paid it off by now anyway?

 

Thanks

Admin1

Re: Charged $10 monthly for 4 years for Inactive eMTA equipment I returned.

Hi seaninwa -- I can help with this modem charge. Please send me a PM with your name, full service address, and either phone number or account number for authentication. I will review your account and have this modem remove. Unfortunately, without proof that this modem was returned we won't be able to refund any of the charges for it. 

 

Click my name (ComcastZach) and click Private Message Me. 

New Poster

Re: Charged $10 monthly for 4 years for Inactive eMTA equipment I returned.

I have been charged an inactive emta for a modem I have returned as well.  I don't have proof of it either.