Community Forum

Blast Pro download speeds ~110Mbps instead of 200Mbps

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Blast Pro download speeds ~110Mbps instead of 200Mbps

I recently upgraded to Blast Pro (from Blast).  After getting my welcome email I tried a Speedtest directly wired to the modem (not via WiFi) and only got around 110 Mbps down and around 10Mbps up.  I tried rebooting the modem and tried again and I'm still getting the same speeds.

 

My modem is an Arris Surfboard SB6141.  I understand this modem is not officially supported by Comcast, but it appears that many others have been able to successfully get 200+ Mbps using this model.  In fact, I asked my chat rep when I signed up for the service if I needed a new modem and he said that I did not.

 

Is it possible I need an updated bootfile sent to the modem?  Any help is greatly appreciated.  Thanks!

Official Employee

Re: Blast Pro download speeds ~110Mbps instead of 200Mbps

Hi dbknightx, thank you for reaching out and it is only the leased Motorola SB6141 that are End of Life.  I am showing you called in after this post were they able to assist getting you the right speeds?

 

Thank you


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!