Community Forum

Audio on nesn channel comes in as Spanish

New Poster

Audio on nesn channel comes in as Spanish

Nesn channel 51 and 851 audio for red Sox games comes in Spanish during the game and mute during the commercials?

New Poster

Re: Audio on nesn channel comes in as Spanish

1 Press XFINITY button
2 Highlight “Main menu” at bottom of screen
3 Highlight SETUP
4 Choose Audio Setup
5 turn off Discriptive Audio Service, then Spanish can turn to English.
6 Hope it doesn’t happen again, but we are on our 4th go around.
Go Sox!