Xfinity plant
Community Forum
Xfinity globe

$60 installation charges

Regular Visitor

$60 installation charges

I originally ordered an internet self installation kit, I hooked everything up myself. There was an issue with connection and I wasn't getting service. Called customer service, representative and I went through the whole troubleshooting process but it didn't solve the problem. She said that most likely there was an issue with outside wiring.She scheduled a tech visit and I was told that I would have to pay $60 for it, but if the problem was outside my home I should call Comcast and would receive $60 credit. When service technician came he checked outside wiring, he found out that cable was disconnected on utility pole and he fixed it. I called customer service and was assured that I would get credit once charges appear on my bill and I contact them about it.I quote the exact words of Comcast representative "This is the new service installation, once you get the bill just give as a call and we will provide adjustment for you. You don't have to worry Sir, everything is documented here" (I have this conversation recorded). On 12/14/17 I received my second bill with $60 charge on it. On 12/16/17 I had a chat session with Comcast rep. about it, he reassured me I would get a credit within a week. It's been 10 days now and I don't see any credit on my Xfinity billing page. This is very frustrating. How do I get that $60 credit I was promised?

Official Employee

Re: $60 installation charges

Hello, and thank you for reaching out to us. I would be happy to assist you from here. Can you verify your account information with me? I would need your phone number, full name, and service address. You can private message me by clicking my name and clicking private message.