Community Forum

camera won't load on app

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

camera won't load on app

Ive had this service for almost 4 months and every update my camera won't load and it one of the reason why I got it. Works on the monitor but not on the app or the web sit. It really makes me upset that I spend money on stuff that don't work
Official Employee

Re: camera won't load on app

Hi brittk0524 - 

 

I've pulled up your account & opened a ticket on your behalf so a tech can reach out to you directly.

 

Thanks,

 

Rachel

New Poster

Re: camera won't load on app

I am having this exact same issue!! How was this fixed?
Official Employee

Re: camera won't load on app

Hi Jamescul24 -- 

 

Thank you for reaching out to us & letting us know!  We have been investigating this issue & believe the camera issues should be resolved.  Can you let us know if you are still experiencing any issues?

 

Thanks!

 

Rachel

New Poster

Re: camera won't load on app

I've been having this issue for weeks now. Camera can't connect on iphone iOS 9/10 Very frustrating. Try to contact chat and it just spins sayind i have zero minutes before someone helps me. I wish you would go back to hard wired camera's or at least have the option.

Contributor

Re: camera won't load on app

The app never shows the cameras unless I'm home and hooked to my wifi. Makes no sense, I've had this service for 3 years and it's never worked good. Why can't they just make it work? And ever since the the update, even the works with xfinity stuff doesn't load up half the time. Fix it already, 3 years is long enough.
New Poster

Re: camera won't load on app

I'm experiencing the same issue of the video not loading on the ios app. When I connect to the home wifi it works, but when I disconnect it does not load the cameras. A service tech was out earlier today and spoke with his supervisor and gave guidance to wait an hour and try again. It is pointless to have cameras if you can't view what is going on when you aren't at home.
Official Employee

Re: camera won't load on app

JimmyB0467, I'd like to look into this for you. Please send me a private message verifying the first and last name of the account holder, and the street address associated with your services. To send a private message click on my name "ComcastChe", then click private message me.