Community Forum

I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Regular Contributor

I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Nest was working fine, then the update today broke it.  I can still see and control the Nest from my iPad which still has the 7.6.1 version of the Xfinity Home app.  However, in my iPhone 6S that was updated to 7.8 the nest does not show up in the Overview page so I cannot see it or control it.

 

I tried everything from restarting the app, rebooting the phone, reinstalling the app, and there is no change.  Please help, I am not sure if it is just me or today's update is buggy.

 

Thanks in advance.

New Poster

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Same thing here. Nest thermostats not working. They show up in the account section, but not in the overview! Please fix asap!!
Regular Contributor

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

I can add that exactly the same happened in my husband's iphone.  Nest thermostats were working fine in 7.6.1, but he when he got home and joined wifi he was automatically updated to 7.8 and he cannot see or control the thermostats anymore.

Official Employee

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Hi kcft & rbeard79  - 

 

I've pulled up both your accounts & have brought this issue to the attention of the correct team for troubleshooting.  I will reach back out to you via the forums for followup.

 

Thanks!

 

Rachel

Problem Solver

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Teams should be testing these updates as soon as they come out to avoid/ minimize the inconveniences that they are causing the XFINITY customers...

Regular Contributor

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Thanks, Rachel. Is there any update on this? Should we expect a new version of the app soon?
Official Employee

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Hi kcft - 

 

We are working on a fix that will be included in the next release.

 

Thanks,

 

Rachel

New Poster

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

I am having the exact same problem, spent a little too much time to realize this was part of the upgrade, it matches the other postings
Regular Contributor

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

I downloaded the update today and the Nest is working again!  Thanks!

Official Employee

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that broke it

Hi kcft --  Thanks for reaching out & letting me know!

 

Anyone else who experienced the Nest issue, please try updating to the latest version of the app as this should resolve the issue for you.  Please let me know if you are still experiencing errors.

 

Thanks,

 

Rachel

New Poster

Re: I was able to add my Nest thermostat but today there was an update to the Xfinity Home app that

My iPhone 6plus still cannot control nest thermostats. On nest app it says XFINITY home has permission but nothing on the XFINITY home app. I have 2 nest thermostats. I have restarted both apps, deleted and added back apps, also made a second nest acct and deleted first to see if this helps, still nothing. SOMEONE PLEASE HELP ME!!!