Xfinity plant
Community Forum
Xfinity globe

Crappy system

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

New Poster

Crappy system

Paying almost $300 per month for not triple play but quadruple play.  On top of that, can't ever get on. System spotting at best.  When I finally do get logged in it only lasts about 2 minutes and then I have to re-log in every 30 seconds after that.  Sometimes after the re-log in it says my system is down.  Get better luck if I go back to previous version.  Please fix the system so it works ALL THE TIME.  Otherwise. . . . the question needs to be asked. . . . am I waisting my money!!! The answer would be. . .ABSOLUTLY!  Do the crooks know how crappy the system is not protecting my investment? ABSOLUTLY!  

Official Employee

Re: Crappy system

Hi linda_mcneill - 

 

Are you having issues signing in to the web-based subscriber portal or the Xfinity Home mobile app?

 

Thanks!

 

Rachel

New Poster

Re: Crappy system

I So agree , We have had nothing but issues with all services since thios sysem was added on. the last 4 days i have not been able to alarm my house from my phone or computer system, Customer service must read from a book or somthing. Trying to be so nice in other words i can not help you deal with it. As soon as my contract is up i am so gone and will never give comcast another service of any kind in my home.

New Poster

Re: Crappy system

nothing but problems w/home security system lately.  Although system is armed, the app indicates that my front door is open.  Called yesterday and they checked everything on their end, didn't see any problems after we refreshed everything.  I'm at work now and the app and desk top site indicate that my system is armed and my front door is open.  Also, I'm experiencing connectivity issues w/the modem.  Was on hold for 30 minutes last night before I finally spoke w/someone who was able to help me.  This morning we're back to square one once again.  Here I am at work, and I can't see anything in my home!  The system is armed and my door is apparently open.  There is no internet at my house, the camera not working on the app or desktop and I had to had up after being on hold for more than 20 minutes waiting to speak with someone.  I'm totally disgusted w/this organization and their service.  You have to wait forever to speak with someone and the only thing they are good at is trying to refresh your equipment.  I think the equipment is faulty!