Community Forum

Xfinity Norton won't install - High Sierra

Frequent Visitor

Xfinity Norton won't install - High Sierra

I just bought a new MacBook Pro and I wanted to install your Norton Internet Security package. I'm running High Sierra. When I try to install via Constant Guard, it asked for my admin password to add Install Helper. Then I get a box that reads: "We are sorry. It seems like something went wrong with the installation of the product. Please contact Support." And a button that reads "Try Later". I tried a few times. What do I need to do next?

Re: Xfinity Norton won't install - High Sierra

Here is a simialr question that hs been solved:

 

https://forums.xfinity.com/t5/Anti-Virus-Software-Internet-Security/When-will-Norton-security-be-ava...

 

 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Xfinity Norton won't install - High Sierra

Hello m_vendetto, were you able to get this installed?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity Norton won't install - High Sierra

I was able to get Norton installed. There were a few things happening. There were some remnants of a Webroot security application that had to be removed and, while MalwareBytes was recommended, it had to be removed as well. Then it wouldn't reinstall after Norton was installed. That's OK though. And I think High Sierra required a different installation procedure than the one that is recommended. Everything running fine now.

Thanks for asking.

- Mike