DohBoi's profile
DohBoi
1st Kudo
1st Best Answer
1st Reply

Regular Visitor

 • 

4 Messages

Mon, Jun 15, 2020 12:00 AM

Cant connect any smart home devices to Xb7 gateway!

So, today I upgraded my internet service and was given the xb7 to replace my 5 year old comcast router/modem. I have spent the last 5 hours trying to connect my smart devices and they just wont connect! The 2.4ghz just seems unresponsive or slow. Some of the devices I am trying to connect are generic wifi/alexa connectors but I have a Dyson fan and the Nanoleaf Aurora panels that wont connect niether! I never had any issues with any of these before and its driving me insane! Is my router defective?

Responses

Accepted Solution

DohBoi

Regular Visitor

 • 

4 Messages

10 m ago

In case anyone is having the same issue and is searching this, my xb7 was defective. replaced modem/router no more issues

darkangelic

Expert

 • 

2K Messages

10 m ago

Many IoT devices are designed to work only with the 2.4 GHz band when you set them up the first time.  Some, like the Amazon Echo, will work with both 2.4 and 5 GHz bands so they're easier to configure.

 

What you probably need to do is to go into your gateway admin panel ( http://10.0.0.1 ), turn off the 5 GHz band temporarily, connect your devices again, then turn it back on. 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
DohBoi

Regular Visitor

 • 

4 Messages

10 m ago

Yeah I seperated my two wifi bands yesterday and I was trying to connect them straight to my 2.4 ghz which now has a different name but it's still not working. I managed to connect a couple LED lights but when I went back to use their apps they had already lost connection.

Tony43

Contributor

 • 

29 Messages

10 m ago

Are your devices connected to homekit or just using apps for each device? You will need to hard reset each device so it forgets the WiFi it helps in its device and also you will need to forget the device on your modem. Having it all cleared out will help with connecting. If your using homekit you need to use homekit directly not the app for the device.

Regular Visitor

 • 

4 Messages

10 m ago

I have a possible answer (I am not an expert!) having searched a number of forums for this issue. The XB7 does not operate at 2.4Ghz on the 802.11b protocol. Some older devices (like the Fitbit Aria Scale, my current nemesis) only connect to 802.11b and will not connect to newer protocols. Check the specs on your devices and make sure they are compatable with the 802.11g/n/ax at 2.4Ghz. If not you may be SOL!

Visitor

 • 

2 Messages

That sol would include me, trying to use the anova precision oven and even though i took steps to separate the 2.4/5 channels,  just realizing with your post that the xb7 does not operate at 2.4ghz on the 802.11b protocol, yet another hurdle.  i sure wish xfinity would warn users about consequences of 'upgrading' with their emails urging us to swap out!  i am just someone who likes to cook, not try to figure out what a 802.11b thing is at a 2.4 ghz.  ugh! 

Tony43

Contributor

 • 

29 Messages

10 m ago

I’m using XB7 and it is compatible as long as it’s two separate 2.4ghz and 5ghz. Don’t merge them.
EG

Expert

 • 

86.2K Messages

1 d ago

@sandycrose 

Please create a new topic of your own here on this board detailing your issue. Thanks. 10 month old dead thread now being closed.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here