airmondii's profile

Regular Visitor


6 Messages

Sat, Mar 7, 2020 9:00 AM

bought and activated new modem. Getting error: NET::ERR_CERT_COMMON_NAME_INVALID

I bought and activated a new modem (Arris SB6190) a few days ago.  Ever since, I will occassionally get blocked from certain webpages due to because "connection is not private".  Also I use a VPN for work and it sometimes fails to connect due to a "security" issue.


see the screen shot below for what I'm talking about.  (EDIT: don't know why the image won't load, so go here:


If I click Advanced -> proceed anyway, I get redirected to the Xfinity device activation page.  It is as if Xfinity temporarily fails to recognize my modem and intercepts my internet traffic.  After I re-activate my device, the original website will successfully load, but then the problem will reemerge a few hours later.  I've probably gone through this process 10 times by now.  I've also tried rebooting my modem several times by now.  And I still get this problem several times a day.  Also, if I do nothing and don't try reactivating the device, usually the problem will eventually go away on its own.  Only to recur later in the day.







86.6K Messages

1 y ago

Try calling 1-800-comcast and ask a rep to completely remove the modem from your account and to "re-provision" it from scratch. Also ask them to confirm that the provisioning and account data in their database is correct and complete. 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here