Brittneedavis's profile

New Poster

 • 

2 Messages

Fri, Jan 22, 2021 8:00 AM

Xfinity Stream Beta App Problems

For the past week I have not been able to use the Xfinity Stream App. I have Un-installed, and reinstalled it. And it presents with a black screen on it and a single white horizontal line across my smart TV screen. I have a newer Samsung Smart TV and this app doesn't work. I have restarted my modem and tested my connection thinking it was the internet, but that didn't seem to help either. Customer service is so hard to get ahold of regarding this app as well.

Responses

New Poster

 • 

2 Messages

5 m ago

Same problem.  Xfinity Beta Whie line across top.  Samsung TV.  Been using Beta for couple years.  It's a terrible app, but I can usually get it to "finally" behave.  This stupid white. line at top behavior is brand new as of couple days ago!

New Poster

 • 

1 Message

5 m ago

Hi there, had the same issue yesterday and had a tech out today. Tech found a few weak signals, BUT my husband unplugged the TV for about 20 min and then the app came back online. Try unplugging the TV for 20-30 minutes. Hope this helps!

New Poster

 • 

1 Message

5 m ago

I have same problem, just got this samsung 8 series tu850D for Christmas, it worked from mid Dec to yesterday Jan 23 2021.  Called Samsung support, they deleted & reinstalled xfinitystreaming app.  Worked one time until I closed & tried to reopen it.  Spent over an hour with comcast tech support but they tried to tell me my tv wasn't supported by the app.  There is an xfinity feature that confirmed my new tv is supported.  I called comcast to disconnect in Nov 2020 because the boxes you rent are too expensive.  The agent told me to buy a new smart tv, get the app & return the box.  I did that & spent $599 at Costco.  Now I have returned the box & can't watch my new tv.  NOT HAPPY 😞  thanks alot Comcast/Xfinity or whatever you want to call yourself.  

New Poster

 • 

2 Messages

5 m ago

Only thing I’ve found to work is to hold back button on remote on white line screen. Then reopen app and repeat until it works again. I did this out of frustration but it worked after the 5th time. Biggest thing was holding back arrow on remote into app closes.

Visitor

 • 

1 Message

Omg this worked! I’ve tried everything and even laughed a little when I read your post but then figured why not since nothing else would work!!! I only had to do it once and the app kicked on 😂😂. Thank you ! 

New Poster

 • 

2 Messages

5 m ago

It’s the app and not the tv.

New Poster

 • 

2 Messages

5 m ago

I have spent a year trying to problem solve the Beta App. I have spent numerous hours on the phone and chats. Techs have come to our home several times. We have a Samsung MU8000. The last three days we have gotten the blank screen with the white line. In the past, we have had constant freezing of programs (not on any other apps), dvr dropping recordings and recoding wrong channels, some days the channels will not change (batteries good and no problem with the controls). A year is enough. We bought a flat indoor antenna for local stations until we can find a better provider. By the way, the antennae is perfect.

New Poster

 • 

1 Message

5 m ago

Same thing for the last couple of weeks...  

 

Symptoms:  After switching to another Samsung TV app and returning back to the Xfinity Streaming App, a blank black scrreen and white/gray line at the top.  Temp fixes found:

  • Unplug TV for about 10 minutes
  • Uninstall/Reinstall the app, but this requires you to re-authorize via the Xfinity.com/authorize
  • Within the Samsung Apps settings, choose reinstall for Xfinity - This works to restore functionality, but if you exit or change to another app and come back, you will have to repeat

New Poster

 • 

1 Message

5 m ago

This worked for me! Thank you.

New Poster

 • 

3 Messages

2 m ago

Same exact issue on my Dell Laptop computer.  It is a distraction even when I select full screen view.

New Poster

 • 

3 Messages

2 m ago

Same problem on full screen when viewing on my Dell Laptop

Visitor

 • 

1 Message

12 d ago

This app needs lots of improvements. FAST FORWARD function sucks! Can’t actually see the video while fast forwarding so it’s impossible to go to a specific spot.  Also, the “smart resume” function is completely gone.  PLEASE FIX IT.  Thank you.

New to the Community?

Start Here