Lynn888's profile

Regular Visitor

 • 

6 Messages

Sat, Jul 17, 2021 11:36 PM

Not receiving Text Messages inside my house.

I have zero or one bar of cell signal inside my house due to the house’s location and elevation in relation to the nearest cell tower.  The weak signal is causing some Text Messages to not arrive on my phone when I’m in the house.  When I walk outside, then I receive several messages all at once.

The cell signal strength at the house has never been great, but seems to have gotten worse around the time I got a new Samsung S21 Ultra phone a month ago. Hard to say for sure that the new phone has poorer signal reception than the old phone.

XM Support had me do a "Reset Network Settings" which did not improve the situation.

Any suggestions?

Anyone have luck with one of the "Cell Phone Signal Booster" units sold on Amazon?

Responses

Accepted Solution

DaveO3

Problem Solver

 • 

352 Messages

2 m ago

WiFi calling is regular calling on your cellphone, except your carrier routes the call over an available WiFi network instead of its cellular network. When you call, your phone automatically selects the best network — cellular or WiFi — you don't need to do anything. It includes calls, SMS, and MMS just like you are connected to a cell tower. For MMS you should have cellular data turned on. 

DaveO3

Problem Solver

 • 

352 Messages

2 m ago

Regular Visitor

 • 

6 Messages

2 m ago

Thanks for the suggestion.  Wifi Calling does help for phone calls, but not for Texting because it's SMS and not internet-based (from what I've read). 

Regular Visitor

 • 

6 Messages

2 m ago

I did a few tests with my phone and my wife's phone. Both are Samsung S21 Ultra.  Setup on each phone:
Disabled Mobile Data.
Enabled Airplane Mode.
Enabled WiFi. 

Was able to send Text/SMS from each phone to the other phone. 

When attempting to send an image (photo or gif), got a prompt to Enable a setting that was something like "Send MMS when cellular service is off". Enabled that setting on both phones. 
Strangely, I'm able to send images from my phone to her phone, but I can't successfully receive an image sent from her phone to my phone. A "Downloading" message appears in the Text thread on my phone. Then after a few minutes it changes to a "Download" button.  When I push the button, it reads "Downloading" (again).  Then after a few minutes changes back to the "Download" button.  Or in one test, the "Download" button just disappeared.  No image was downloaded/received on my phone during the tests.  Seems odd for 2 new, identical phones to not be consistent in how they receive MMS when their settings are the same. 

DaveO3

Problem Solver

 • 

352 Messages

2 m ago

There are two issues to be aware of:

1.) XM has to think that you have cellular data enabled, even though you are on airplane mode, since XM charges your  mobile data limit used for MMS, whether using cellular or WiFi Calling. Try turning off airplane mode, turning on cellular data, then turn on airplane mode again, and run some more tests. 
2.) XM has a roughly 600kb limit on an MMS, though it might try to compress it for you. 

Regular Visitor

 • 

6 Messages

2 m ago

I followed your suggested sequence of steps and had good results. 
(One note: When I turned on airplane mode "again", Mobile Data and WiFi automatically Disable. So I enabled WiFi.)
I was able to receive SMS and MMS on my phone. First with a small gif and then with a 4MB photo.  It was 4MB when sent from my wife's phone and arrived at my phone as 840KB. 
I was also able to send SMS and MMS from my phone to my wife's phone. 

Thanks for the help. 

DaveO3

Problem Solver

 • 

352 Messages

2 m ago

Now for the next test! Is your cell signal bad enough so that your phones will switch to WiFi Calling without having to turn on airplane mode when you go into your house? If this is the case then you won’t have to turn airplane mode on and off when you enter and leave your house, and your phones should automatically hand off between your tower and your WiFi. 

New to the Community?

Start Here