Kft0212's profile

New Poster

 • 

3 Messages

Tue, Jan 28, 2020 4:00 PM

Xfinity App login loop

I have been dealing with the login loop issue for months when using Xhome and XFi apps on my iPhone. I’ve called support spent way to much time with Comcast and Apple with no solution. The only fix I’ve found is to reset my entire phone to factory settings. HELP

Responses

XfinityAmira

Official Employee

 • 

2.4K Messages

1 y ago

Hello @Kft0212, thanks for reaching out to our Forums! I apologize for the delay in responding to you and to hear about this ongoing app login loop you have been experiencing. We definitely want to further look into this and get it corrected. Can you please send me a Private Message including your first and last name as it appears on the account? 

 

To send me a Private Message, please click my name “ComcastAmira” and click “send a message". 

New Poster

 • 

2 Messages

2 m ago

I am having the same issue; how did you resolve it? My issue started after I installed a new modem that Xfinity said I needed to take advantage of the speeds that my plan provided.

Visitor

 • 

1 Message

1 m ago

The Xfinity Home App looping problem is not your IPhone. I am having the same issue and I have a brand new Samsung G21 phone. This is the second time within one week. I chatted with Xfinity Home Rep and all she did was send a refresh signal and the app started working immediately. My concern is that if I hear loud noises outside and I don't want to go outside to investigate, I won't be able to access my Xfinity Cameras because the app only loops. One would think Xfinity Home would fix this issue for the sake of their customer's security.

New to the Community?

Start Here