U

Visitor

 • 

1 Message

Thu, Sep 9, 2021 2:25 PM

I can’t log into xfinity app keeps redirecting me back to sign in and i have tried on multiple devices

My wifi just stopped working a few days ago and keeps telling me to activate I’ve been an xfinity customer for nearly 3 years now. I’ve been using the same WiFi for the same period aswell why do I need to deactivate my account, and on top of everything I can’t deactivate my account because the app won’t let me I tried on 4 other devices to fix this issue because will thought it was my phone. But no I was wrong the problem is the xfinity app. I logged in on a 1 plus a galaxy a1 an iPhone X s and a galaxy s8 I want my wifi back asap please resolve this issue 

Official Employee

 • 

378 Messages

2 m ago

Greetings, @user_7d3851! Thanks for reaching out by knocking on our virtual door here over our forums page. I am sorry to learn about this experience with the wifi connection. We appreciate your business for over 3 years now. You have reached the best team over social media to help with service issues such as this. It is important to us to get this fixed for you as a reliable internet service connection is so critical to have these days. To research this further and get this fixed, would you mind sending us a direct message with your first/last name and full address? You can start by clicking the chat icon located in the top right corner of your forums page when signed in. Once there, you can search for "Xfinity Support" to compose your direct message. Once I receive this information, I will be able to pull up the account and take a look at what’s going on.

New to the Community?

Start Here