K

Visitor

 • 

1 Message

Wed, Dec 1, 2021 1:45 AM

XFI App Not Working

I’ve tried for 3 days to log in. It says that it’s using the Xfinity account to sign in. Then it shows the blue dots for about 30 seconds, then says it didn’t work and try again. I’ve tried on Wi-Fi and LTE, reset phone, deleted and reinstalled the app. Help

Official Employee

 • 

2.7K Messages

2 m ago

Hello there, @KSRohwer

 

Lets take a look into your account together. Can you please send us a private message with your full name and service address? We can run some trouble shooting to help with the xFi app. To send the requested information:
  • Click "Sign In" if necessary
  • Click the "Direct Messaging" icon 
  • Click the "New message" (pencil and paper) icon
  • The "To:" line prompts you to "Type the name of a person". Instead, type "Xfinity Support"
      there. As you are typing a drop-down list appears.
  • Select "Xfinity Support" from that list. An "Xfinity Support" graphic replaces the "To:" line.
  • Type your message in the text area near the bottom of the window
  • Press Enter to send it

New to the Community?

Start Here