U

Visitor

 • 

2 Messages

Wed, Jun 1, 2022 1:08 AM

Slow android apps

Having the same issue. When connected to home Xfinity wifi, several android apps don't load or load very slowly.  If I turn off wifi or connect to a different wifi, everything is lightning fast. 

Official Employee

 • 

233 Messages

4 m ago

Oh gosh, I'm sorry to hear that. Does this only happen on the one device, or is it happening on multiple devices? 

Visitor

 • 

2 Messages

@XfinityKyla​ It only happens on my Android phone.  Several apps just hang when I'm using my home wifi.  If I turn it off, everything works fine and they work fine on all other wifi networks.  I have rebooted my modem several times.  This has been going on for months.

Official Employee

 • 

97 Messages

Thanks for following up with us, and I'm sorry you still have that issue. Can you please send us a private modmail message, so we can further help? Here are the instructions on how to send it:

 

Click the "New message" (pencil and paper) icon 


The "To:" line prompts you to "Type a person's name". Instead, type "Xfinity Support" there.
 
As you are typing a drop-down list appears. Select "Xfinity Support" from that list.
 
An "Xfinity Support" graphic replaces the "To:" line.
 
Type your message in the text area near the bottom of the window
 
Press Enter to send it.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

4 m ago

This is happening to me also. I have a Huawei P30 Pro android device with T-Mobile sim and when connected to WiFi my apps take ages to load (sometimes not at all) but when I turn off the WiFi they load immediately. Even the xfinity app is slow over the WiFi! Any ideas or suggestions? 

XfinityPaula

Official Employee

 • 

356 Messages

@Hight0wer There are some steps we can take and troubleshoot. Do you have any other devices on the network that has the same issue? If we can narrow it down to the network or the device that will help us figure out which side we need to investigate. 

Personally I have a Google pixel 4 through t-mobile with Xfinity home internet and I don't see a lag on app or sites. On occasion, I have needed to close the app and restart it, but it was one app that was having an issue, not multiple. 

What version android is the phone running? Has it been updated recently? Has the latency always happened or does it seem to be a new issue?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

Hi,

All cell devices in my house are in T-Mobile and are new. I downloaded a news app (BBC news) to my wife's phone (REVVL V5+ on T-Mobile) and the same latency issue happens. 

What version android is the phone running?

EMEI 12.0

Has it been updated recently?

Yes, It's kept up to date always. 

Has the latency always happened or does it seem to be a new issue? I only moved to the android recently as my provider switched from Sprint to T-Mobile. 

If I try connect to an app (e.g. Strava sports app) with my WiFi on, it hangs, if I switch to mobile data, it instantly loads.

Thanks 

Official Employee

 • 

382 Messages

@Hight0wer Thank you for that informaiton. Is it just the phones that you notice the issue on? How many devices do you have  connected to the modem. I know that the more devices I connect to the modem through Wi-Fi the slower the speeds are. 

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

6 Messages

Hi,

In total there are 7 devices connected to the WiFi (2 tvs, 1 laptop, 1 ipad, 3 cell phones and a sonos sound bar). Most of the time these are on standby when I'm attempting to use the apps I mentioned and still there is lag/latency issues. But the other devices don't have issues like the cell phones do

user_MikeG

Contributor

 • 

71 Messages

I appreciate the clarification! With our gateways, there are 2 bands. There is the 2.4 GHZ and the 5.0 GHZ bands. Normally the 2.4 GHZ band is slower but provides better coverage, so I want to get some additional information. Are you experiencing this issue both when you're close to the modem (within a few feet) and further away?

forum icon

New to the Community?

Start Here