U

Visitor

 • 

4 Messages

Fri, Apr 22, 2022 12:27 AM

No Xfinity ID?/Xfinity ID Not Linked to Address?/Hours with support on the phone no solution...

I have already spent a couple of hours on the phone with Xfinity Support on the phone to try and get a solution... No dice... Perhaps someone here can fix it


Signed up for Xfinity internet a couple of days ago. Im having several issues:

1) When I log into the Xfinity App it says I need Xfinity internet to continue using the app...
2) When I try to go into various sections on the Xfinity Internet website such as My accounts/Billing etc... It logs me out saying a communication error has happened please reload etc.... (Googling I see a lot of people get this...)
3) Similar stuff happens on the mobile side of things if I try to sign up for mobile it either does not proceed and logs out or said I had to be an internet customer...
4) The internet at home is not working.



Yes I have tried clearing cache/cookies. Ive tried using 2 different browsers (firefox/chrome). Ive tried using cellphone and laptop. Ive tried using 2 different internet connections and problems 1-3 still happen.


And no I have not had an Xfinity/Comcast account before, I just moved here from Canada. Support on the phone suggested that might be the issue but no1 fixed it successfully.


I have already sent a direct message to Xfinity Support here as of yesterday with all of the above and my account #/identifying stuff, and have not gotten a response. Im assuming you have to flag me or something so someone responds... hence this post...

Official Employee

 • 

3.2K Messages

4 m ago

Hi there. So sorry to hear you're having so much difficulty right off the bat! You're in the right place for help. In the future, please make sure to not send us private messages (DM's) unless we specifically ask you to do so. Otherwise, they're considered unsolicited. You can view our Community Guidelines here: https://forums.xfinity.com/conversations/guidelines/xfinity-forum-guidelines/602da8fdc5375f08cd20b38c and here: https://forums.xfinity.com/conversations/guidelines/xfinity-forum-acceptable-use-policy/602d9c64c5375f08cd574236.

 

Since you're a new customer, please try following the prompts listed here to work out and issue with your Xfinity ID if there is one: https://idm.xfinity.com/myaccount/lookup?execution=e1s1. Otherwise, we're going to want to focus on your installation and whether you did a self install or a had a professional installation. If you self installed your equipment, how did that go? Did you just move to this location or are you just new to Xfinity? These are major factors and things we'll need to get into/consider in order to reach a solution. 

{hyperlink correction}

(edited)

Visitor

 • 

4 Messages

4 m ago

I've already tried the ID link it gives me:

"Let's try that again.
Sorry, we ran into a problem. Please give us a minute and then try again.

If the problem persists, please contact us and we'll take care of it as quickly as possible."

When trying to verify via email. It does not successfully send me texts to verify it that way. I am texting and calling  other people absolutely fine, I will call Xfinity Support off my number and they are not able to send me texts either ?? (It is a Canadian phone number still). I cannot verify via SSN yet.

____________________

I just moved to the address for the first time. I just signed up for Xfinity for the first time.
____________________

Self install. The Modem MAC/Serial were added by support on the phone.
Going directly from Coaxial -> Modem -> Hardwired ethernet into laptop. No internet but it gives me the network login page that includes this text:

"Welcome to Xfinity!

Download the Xfinity app on your mobile phone to activate your internet in minutes.

Make sure your phone is on your cellular network and click the appropriate link below to get started."



Great. Except when I go into the app and login it says "You Need Xfinity Internet to Continue".


Support on the phone has already booked a tech to come on Saturday for the physical side of things... But the issues are even before that with the actual account and ID.

(edited)

Official Employee

 • 

3.2K Messages

Let's talk more about the modem and what solid lights you're seeing on it. How many lights are currently on and solid? Also, do you have multiple outlets/cable jacks inside this premise? It's quite possible the one you have the modem currently plugged into isn't active/wired for Xfinity. Otherwise if you only have one and it's not working, there's a chance that the tenants before may have had a different provider, which would mean that you'll need a professional installation so we can run a new line, and activate the outlet. In the meantime, I'll be taking a look at the ID concern on this end. Please send the email/username you're currently trying to use and log in with via DM.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

I have sent all of that info via DM thanks.

forum icon

New to the Community?

Start Here