U

Visitor

 • 

2 Messages

Sun, Mar 27, 2022 7:31 AM

Hmm, the page didn't load correctly

I'm trying to access my account page at https://customer.xfinity.com/?beta=1. However, I get the message "Hmm, the page didn't load correctly" across different devices and browsers. I recently signed up for an account today. In another support thread, someone suggested creating another XFinity ID via http://comca.st/3N2Octp and linking the new account to the old one.

However, I was unable to create a new ID; the error message was "This information doesn't match our records." However, I'm sure I used the correct phone number, because I received a verification text from Xfinity earlier today when I signed up.

Accepted Solution

Official Employee

 • 

3.3K Messages

5 m ago

Hello @user_5b8353!

I'm excited to hear you are signing up for Xfinity services and I'd love to help you through this process!

 

If you signed up online, sometimes it takes a bit for the account to fully build itself within our systems so that you can set up your new username and login information. 

 

Another thing that may be happening, is that if the address or information you are entering isn't 100% matching (happens most commonly with locations on the edges of two cities), then our system won't be able to recognize it.

 

Either way, I would be more than happy to gather your information and take a closer look to see what the status of your new account is and figure out what your next steps will be! 

Please send us a direct message with your first/last name and service address so I can help.

 

 

To send a Direct Message, please click on the chat icon on the top right of this page, next to the bell. Make sure to send the message to our singular handle "Xfinity Support" and we will get back to you ASAP.

Visitor

 • 

1 Message

@XfinityTambrey​ I am having the same problem- and it is impossible to get a hold of a person to help

XfinityAbbie

Official Employee

 • 

1K Messages

@user_32026c Hello and thank you for letting us know you are having issues with this. You reached the right team, and we can assist. 

 

Please send a private message by clicking the direct messaging chat icon in the upper right corner of the page, click on the pen and paper icon, then enter “Xfinity Support” in the “To” section. Please include your name and address and I'll be happy to help.

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

I'm having the same problem. Just signed up for xfinity today and getting the same message "Hmm, the page didn't load correctly"   i do not see any chat icon to ask for help.  Not good for just starting new service. HELP!!!!!!

Official Employee

 • 

97 Messages

Hello, @user_43c105 I'm very sorry for the trouble that you are having. You reached the right team, and we can assist. 

 

Please send a private message by clicking the direct messaging chat icon in the upper right corner of the page, click on the pen and paper icon, then enter “Xfinity Support” in the “To” section. Please include your name and address and I'll be happy to help.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Accepted Solution

Visitor

 • 

2 Messages

5 m ago

For anyone else in the future: my account was not fully created. The support team could not find an active account at the address I provided, my account associated with the email address, or a pending order associated with my phone number.

When I went through the same sign-up/order flow again and provided the same phone number and email address, it was able to retrieve my Xfinity profile somehow. This time, the order was able to be placed, and I could access my account page afterwards. Looking at the "Recent Activities" section in the account page, I confirmed that I did not accidentally place the order twice, and it was only the second attempt that was successful.

Visitor

 • 

1 Message

1 m ago

I have the same problem and I don't see any chat icon ??

Official Employee

 • 

423 Messages

You will need to sign in to the forums and then create a post publicly, so we can further assist you. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

1 Message

13 d ago

The solution of signing out and going through the ordering flow worked for me! Thanks user_5b8353!

forum icon

New to the Community?

Start Here