U

Visitor

 • 

8 Messages

Thu, Mar 25, 2021 5:56 PM

Outlook 2016 for Mac unable to make secure connection to server

I have been running Outlook for the Mac for 5 years and this month I just started getting this error that Outlook can no longer make a secure connection to the  smtp.comcast.net server.     I then get asked to accept a COMODO certificate and I can again work but that connection is not secure and Outlook will not let me send anything labeled confidential.  Any words of advice will be appreciated.

Responses

Visitor

 • 

8 Messages

3 m ago

This is what I get when I try to do a send and receive .

Official Employee

 • 

210 Messages

Hey there ! Thanks for reaching out. Have you confirmed all the settings are correct for your clientt? https://comca.st/3dxtGR5

 

  • Incoming Mail Server Name: imap.comcast.net
  • Incoming Mail Server Port Number:
    • Recommended: 993 with SSL ON
    • Only if Needed: 143 with SSL ON
  • Outgoing Mail Server Name: smtp.comcast.net
  • Outgoing Mail Server Port Number:
    • Recommended: 587 (SMTP)
    • Only if Needed: 465 (SMTPS)
  • SSL Encryption: checked
  • Authentication: XFINITY username and password required

(edited)

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Visitor

 • 

8 Messages

No I was using mail.comcast.net and smtp.comcast.net.  I will try the addresses you listed. 

Visitor

 • 

8 Messages

Exact same error Connection to the server failed or was dropped.

Visitor

 • 

8 Messages

one caveat if the document has no attachments or the email is not listed as confidential it sends fine.  Just outlook keeps telling me that a secure connection could not be made.

Again

Expert

 • 

25.8K Messages

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Visitor

 • 

8 Messages

2 m ago

Thank you both for the suggestions. Unfortunately, neither of these solutions helped.  My Comcast settings are exactly what they are supposed to be.  From what I can tell Comcast did something to the server side certificate that is causing this.   As I said earlier.  I have been using outlook for years with my Comcast email. This just started last week.

Visitor

 • 

8 Messages

1 m ago

OK so after contacting Microsoft support ( they were great). We found out that Norton 360 had a major issue with Big Sur and Outlook.  Norton is working on it.   Thanks for the suggestion to contact MS support.

New Poster

 • 

2 Messages

1 m ago

I have the same issue -- MS Outlook support say Comcast needs to look into this -- it seems to be an issue with many. The connection error code is 16997 & 17099. Apple support also indicated it seems to be a Comcast configuration issue. I have reported this to Comcast Support, but have not heard back.

Again

Expert

 • 

25.8K Messages

@finkel

Did you check the link I provided above to see if it applied to you?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Visitor

 • 

8 Messages

@finkel   open up norton and disable the firewall and see if the problem goes away.

New Poster

 • 

2 Messages

@user_056e0a  Thank you for your post!  I was having the same issue.  Disabling Norton firewall did indeed resolve my problem.  Hopefully Norton and MS can get together and resolve this.

(edited)

New to the Community?

Start Here