U

Visitor

 • 

2 Messages

Thu, Dec 2, 2021 12:37 AM

work order ignored for 2 months

Drops in upload speed from 20Mbps down as low as .9 and stays down. Had a tech come out 2 Months ago, New junction box mounted on house, new line from house to road. Upload speed was still all over the pace. He turned in a ticket and there it has sit. About 3 weeks ago, anther tech was sent to my house, he checked everything and changed the modem telling me it will not fix a line problem down the road, he was right,, and now the problem is still there only worse. Another tech came yesterday, he checked the speeds in house and out at the pole, he said the same thing ,, problem is in the lines down the road. He called his "field supervisor" who came over and he check and said yes, there was an open ticked posted 2 months ago, He made a few calls and then told me it would be fix TODAY! And NO it is still 1.64Mbps upload.  Why is this being ignored? Not getting what I pay for ,, not even close.  Suggestions ? 

Accepted Solution

Visitor

 • 

2 Messages

6 m ago

ok,, done with the chat thing ,,, full of scripted copy paste replies and no help,,, just wasted another hour of my time. 

EG

Expert

 • 

93.8K Messages

6 m ago

Concern moved here to the Customer Service help section for greater exposure to actual Comcast corporate employees (The Digital Care Team) for assistance.

XfinityDena

Official Employee

 • 

602 Messages

6 m ago

I do want to thank you so much for taking the time out of your day to reach out through our Forums Channel. I can tell you have not had the best experience and I assure you I am here to do everything I can to turn this around. We appreciate your signing up to be a part of the Comcast family, and I want to be sure we can get everything figured out for you with your service. Please send me a Direct Message with your name and service address so that I can fully dive into this for you! I will leave you instructions on how to initiate the message with us! I look forward to working with you soon!


- Click "Sign In" if necessary
- Click the "Direct Message" icon (upper right corner of this page)
- Click the "New message" (pencil and paper) icon
- Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list
- Type your message in the text area near the bottom of the window
- Press Enter to send your message

forum icon

New to the Community?

Start Here