William_Zane's profile

New Poster

 • 

1 Message

Mon, Jan 18, 2021 9:00 AM

Never received home Assessment

I have very slow to no internet in parts of my home I have the XFI complete package I've checked spam and nothing I know that I would qualify for the XFI pods please help

Responses

ComcastMichele

Official Employee

 • 

322 Messages

2 m ago

@William_Zane Thanks so much for taking the time to reach out to us regarding your slow connection. I very much appreciate your patience and greatly apologize for the delay in our response. I know how important the services are to your home and we want to do all that we can to assist. I rely on my connection for everything and I know how frustrating and impactful a slow connection can be. I would love to get to the bottom of the connection issues that you are experiencing. Can you please reach out through private message with your first and last name, name on the account if different, and service address? If you’re having trouble locating this information, you can also reference our world-class MyAccount app to view all of your account details by the simple touch of your fingertips! Please follow the process here to learn how to obtain that information: https://comca.st/3oCQe6o

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here