Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,970

members

1,017

online

29,066

topics

Top

Xninity router - Can't assign static IP address

New Poster

Xninity router - Can't assign static IP address

I log into my Xfinity router at 10.0.0.1 with web browser

I go to "Connected Devices > Devices"

In the "Online Decvices" list I find the device for which I want to assign a fixed IP address and click the Edit button

I change the configuration from "DHCP" to "Reserved IP". The page updates and properly shows the currently allocated IP address (10.0.0.5 - the address that was assigned by the DHCP server)

I click the "SAVE" button and get the error "IP address already exist"

 

Then I try to assign an IP that I know is not currently in use.

I click the "SAVE" button and get the error "MAC address already exist"

 

Then I try to create a bogus device with a random MAC address and the IP address 10.0.0.100 (both MAN and IP addresses are not currently in use)

I click the "SAVE" button and get the error "10.0.0.100 is inside the DHCP pool"

 

So it looks like there is no way to specifiy a static IP address. I was able to do that maybe a year ago. It looks like Xfinity updated the firmware and introduced a bug.

 

Anybody has come accross this? Any solutions?

 

Thanks,

 

New Poster

Re: Xninity router - Can't assign static IP address

I'm having the same issue.  Comcast - any help???

New Poster

Re: Xninity router - Can't assign static IP address

same issue

comcast could not help

I knew more about routers than their tech help

pitiful


mbelanger wrote:

I log into my Xfinity router at 10.0.0.1 with web browser

I go to "Connected Devices > Devices"

In the "Online Decvices" list I find the device for which I want to assign a fixed IP address and click the Edit button

I change the configuration from "DHCP" to "Reserved IP". The page updates and properly shows the currently allocated IP address (10.0.0.5 - the address that was assigned by the DHCP server)

I click the "SAVE" button and get the error "IP address already exist"

 

Then I try to assign an IP that I know is not currently in use.

I click the "SAVE" button and get the error "MAC address already exist"

 

Then I try to create a bogus device with a random MAC address and the IP address 10.0.0.100 (both MAN and IP addresses are not currently in use)

I click the "SAVE" button and get the error "10.0.0.100 is inside the DHCP pool"

 

So it looks like there is no way to specifiy a static IP address. I was able to do that maybe a year ago. It looks like Xfinity updated the firmware and introduced a bug.

 

Anybody has come accross this? Any solutions?

 

Thanks,

 


 

Highlighted
Connection Expert

Re: Xninity router - Can't assign static IP address

Dead thread from last year now being closed. Please create a new topic of your own here detailing your issue.



Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 3 replies
  • 1542 views
  • 0 kudos
  • 4 in conversation