Xfinity plant
Xfinity globe
Community Forum

WiFi speeds not what I paid for.

Regular Visitor

WiFi speeds not what I paid for.

The speeds I am getting are Performance, while I should be getting Blast Pro speeds around 250mbps. If anyone can help. Thanks.

Official Employee

Re: WiFi speeds not what I paid for.

Hi, Wellson - The WiFi speed is always lower than hardwired. Did you try to check your speed via the direct connection from the modem to your PC? Please refer to the article from XFINITY Knowledge Base about how to improve your WiFi speed: http://forums.xfinity.com/t5/Internet/ANSWERED-How-to-improve-your-Xfinity-Wifi/ta-p/2940646

 

Also, please do not send private messages to moderators without a request. Sending unsolicited private messages to moderators or any other user is a direct violation of our forum guidelines. Per those guidelines, and continued violations you could be subject to a revocation of your Xfinity Forum privileges. We never want to get to that point with any user so we recommend reviewing those guidelines thoroughly.

 

Please let me know if you have any questions. 

Expert

Re: WiFi speeds not what I paid for.

Also see: troubleshooting guide. If you still need help, please post your equipment details (make/model of your modem/gateway/router) and a screenshot of your signal levels and your error/event log. Thank you!

Regular Visitor

Re: WiFi speeds not what I paid for.

Even the Ethernet hardwired doesn’t work, it’s still around 80 mbps

Expert

Re: WiFi speeds not what I paid for.

We can't offer much help unless you provide more details. Please see my previous post 

Admin1

Re: WiFi speeds not what I paid for.

Wellson -- Are you able to provide the requested information from nerdburg? This will help us in our efforts to correct your speed issues. 

Regular Visitor

Re: WiFi speeds not what I paid for.

By signal levels do you mean the signal detection my the gateway?
Regular Visitor

Re: WiFi speeds not what I paid for.

Model TG1682G
Official Employee

Re: WiFi speeds not what I paid for.

@Wellson - Please send me a private message with your full name, the account holder's name as it listed on the billing statement, a phone or an account number. I will check if there are any issues with your RF signal levels. Thank you!