Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,665,041

members

48

online now

1,836,867

discussions

Back to Top

Stunningly poor IPv6 tech support - Modem in Bridge Mode for IPv6 assignment

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 10
462 Views

I've been on the phone for over 3 hours (3 hours!) trying to get ANYONE who speaks IPv6.   Every "engineer" I speak with has no clue what it is - they all try to "fix" the problem by reseting the modem or taking it out of bridge mode.  The last one transferred me to wifi support.

 

I have a Cisco ASA-5515-x that I've configured the outside interface for IPv6 DHCP client and autoconfig.    If the modem is not in bridge mode, it assigns my IPv6 outside address correctly.  However, since that prefix is for my inside network, assigning it to my outside interface is of no help.   Once I put them modem in bridge mode, the ASA no longer receives its DHCP assignment presumabely from the upstream DHCPv6 server.

 

Any help would be appriciated.

9 REPLIES
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 10
422 Views

I give up.  Comcast wins.

Tech support reset my modem no less than 10 times - twice while I was talking to them via WiFi and telling them NOT to reset the modem.

Not a single engineer understood why I needed to have bridge mode enabled.

Not a single engineer could speak to how IPv6 works.

Not a single engineer could transfer me to someone who could help.

So back to IPv4.

Posted by
Regular Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 10
402 Views

It sounds like bridge mode in your modem/router combination isn't as transparent as a should be.   Why not ditch it and buy a straight modem.   Lots of us with our own modems have no problem running over IPv6.   

Posted by
Connection Expert

Message 4 of 10
390 Views

Do you also have their phone service ?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 10
373 Views
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 10
372 Views

Because the package I have required their modem.  Package gave me phone service which I didn't use for MONTHS until my wife needed to send a large fax Smiley Happy.  Now its a fax line.

Posted by
Connection Expert

Message 7 of 10
367 Views

O/k so if you want to keep and use their phone service, and you want to "ditch" their device (as suggested by others) and purchase your own device, (it can't be a "straight cable modem" as others have suggested). Bear this in mind;

 

FWIW, there *may still* be one caveat to owning your own eMTA or gateway device that supports their phone service. YMMV. I always advise (until I'm told otherwise officially) that the first thing you should do is to call in or go to your local CC service center (the better choice) and inquire / confirm as to whether or not customer owned eMTA's (modems with phone support) are allowed to be used on the local system. Some local franchises still do not allow it and require you to rent one from CC. The personnel that work there seem to better know what the actual local franchise's policies really are than do support reps at the national 800 number.

If allowed, there are five devices available at retail that they will activate for service are the Arris TG862G, the Arris SVG2482AC, the Netgear C7100V, the Arris TM822G, and the Arris TM722G. The 862 is a combo cable modem / router / eMTA gateway device but it is a piece of junk. But it can be put in to bridge mode so that it acts only as a cable modem with phone support. You would the use your own high quality stand-alone router with it.

The SVG2482AC and the C7100V are much better performing combo gateway devices that offer 24 downstream channels. The 822 is an eMTA that offers only 8 downstream channels. The 722 is an older eMTA that offers only 4 downstream channel bonding capability so it won't be able deliver their fastest speed tiers like 150 and faster. They are hard to find as they are not being manufactured anymore.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Contributor

Message 8 of 10
349 Views
Does your ASA have setting for DHCPv6 with Prefix Delegation?
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 10
193 Views

Found 1 issue after HOURS of support from Cisco - the Hop Limit field in the IPv6 header for DHCPv6 packets from Xfinity was set to 0 so all of the DHCPv6 advertisements were bing (correctly) dropped by the ASA.   More hours on the phone trying to find the right comcast "engineer" to fix it.   Finally receiving a /128 address on my outside interface.   However, I'm unable to assign any of my inside interfaces

!

interface GigabitEthernet0/0
nameif Outside
security-level 0
ip address dhcp setroute
ipv6 address dhcp default
ipv6 enable
ipv6 nd suppress-ra
ipv6 dhcp client pd hint ::/56
ipv6 dhcp client pd prefix-from-Comcast
!
interface GigabitEthernet0/1
nameif Inside
security-level 100
ip address 192.168.1.1 255.255.255.0
ipv6 address prefix-from-Comcast ::1:0:0:0:1/64
ipv6 address autoconfig
ipv6 enable
!

 

vpn(config-if)# sh ipv6 int
Outside is up, line protocol is up

IPv6 is enabled, link-local address is fe80::206:f6ff:fe2b:2feb
Global unicast address(es):
2601:681:xxxx:xxxx::7356, subnet is 2601:681:xxxx:xxxx::7356/128
Joined group address(es):
ff02::1:ff00:7356
ff02::2
ff02::1:ff2b:2feb
ff02::1
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
Hosts use stateless autoconfig for addresses.


Inside is up, line protocol is up
IPv6 is enabled, link-local address is fe80::206:f6ff:fe2b:2fe8
No global unicast address is configured

Joined group address(es):
ff02::1:ff2b:2fe8
ff02::2
ff02::1
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 1000 milliseconds
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
Hosts use stateless autoconfig for addresses.
vpn(config-if)#

 

 

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 10
85 Views

aaaaannddd we're back to not receiving an IPv6 address on the outside interface.

 

Gota love Comcast...  Briliant engineers there.