Xfinity plant
Xfinity globe
Community Forum

Speed Decrease

Frequent Visitor

Speed Decrease

I've been running a Netgear CM600 for quite some time on the 250 plan, and have tested closer to 300/30.  Steam downloads and such have been between 35-37.5MB/s (big . Last Thursday the speed dropped to about 160Mbps tested, and downloads are stuck at 20MB/s.

 

I contacted support via chat, and after the usual resetting and rebooting and bypassing of router, nothing was improved.  A service call was scheduled, then the rep convinced me to upgrade to gigabit.  I was *very* clear (and saved the chat) that I had no interest in actually using the phone product that was part of the package, nor did I want to use the Comcast gateway, preferring to get a modem myself.  I was told that I could have the XB6 installed, then return it to a store and use my own.  They also said that I could cancel phone service after a year.

 

The original service call was cancelled in favor of an installation.  When the installer arrived I first made sure that we were OK using the MB8600 I'd gotten.  He called his office and they said that no, I *had* to use (and keep) their stuff.  I had them cancel the upgrade order and asked the installer if he could try to fix my service and get me back to where I was last week.

 

More rebooting, modem swapping between my CM600 and the gateway he had brought for the now cancelled upgrade, ethernet cables, PCs, wireless, wired, etc.  Every test came up deficient in the same way.  He replaced the cable end outside in their box in the back yard.  The modem(s) continued to test OK as always, so he said he couldn't fix it and left.

 

I'm left with a connection that's about 100Mbps short, and that was working until last Thursday.  I've got a tech coming in the morning, but I'm not confident that they'll entertain any options beyond cabling in the house.  What are the odds that it's a problem beyond the box in the back yard, where the cable from my house connects?


Accepted Solutions
Frequent Visitor

Re: Speed Decrease

Well, the update is that after a ton of equipment swapping, three techs saying that they couldn't figure it out, and more speed tests than I thought possible, I went ahead and upgraded to gigabit with my own MB8600.  The problem remained, only a *little* faster.  Some things were consistently slow, some were fast.

 

I have no idea what ended up fixing it, but two days later someone hit the gas.  Everything is now as it should have been. If I had to guess, there were some lingering Comcast/Cogent issues that got resolved.

 

 


All Replies
Frequent Visitor

Re: Speed Decrease

Oh good. An emoji showed up unbidden.

 

That was supposed to indicate that the use of a capital b was on purpose.

Expert

Re: Speed Decrease

Start here: troubleshooting guide. Please post your equipment details (make/model of your modem/gateway/router) and a screenshot of your signal levels and your error/event log.

Frequent Visitor

Re: Speed Decrease

Route is "normal" most times, with occasional sticky points.

event 1.PNG
event 2.PNG
route.PNG
signal.PNG
route ipv4.PNG
Expert

Re: Speed Decrease


@mafu wrote:

Oh good. An emoji showed up unbidden.

 

That was supposed to indicate that the use of a capital b was on purpose.


LOL Yeah, it does it to me too, it figures that if you use a parenthesis, you must be trying to make an emoji. 

Frequent Visitor

Re: Speed Decrease

Today at about 11am was when I rebooted everything after the installer left.  The 15th was when I noticed the slowdown.

Expert

Re: Speed Decrease

How are your upstream levels?

Expert

Re: Speed Decrease

And you're testing speeds directly connected to the modem via ethernet?

Frequent Visitor

Re: Speed Decrease

Yes, still ethernet directly to modem, gigabit on both ends.

upstream.PNG
Frequent Visitor

Re: Speed Decrease

And I just realized that I had it back to router mode to see why wireless was testing faster but downloading the same.  Here's some routes with wired directly to modem. 

 

I looked right at the RT-AC68U several times. It's been a long day.

direct ipv4.PNG
direct ipv6.PNG
Expert

Re: Speed Decrease

I don't see any red flags. I know you have a tech coming in the morning, but I asked an employee to take a look at your account and your node health anyhow, they can see some values that we can't and they can see how things are in your neighborhood. You can expect a reply in this thread. 

Frequent Visitor

Re: Speed Decrease

Thanks so much.  If we can get this figured out I'd feel a lot better about looking at gigabit again, if we can come to an agreement about equipment Smiley Happy

Frequent Visitor

Re: Speed Decrease

Just FYI, the tech just left.  He said "the signal is fine and there's nothing I can do".  I asked him to look wider, so he looked at "timeline" and said there's no problem.

 

I appreciate your attempt at help.  If I don't hear anything from a tech here that actually matters, I'll be switching back to AT&T - and taking a massive speed hit in favor of much more reliable service.

Expert

Re: Speed Decrease

@mafu

Eh, sorry to hear that. Hang tight for a just a little longer. I did ask a corporate employee to take a look at your account and node health. I know they are backed up right now, but they should be getting to you soon. 

Frequent Visitor

Re: Speed Decrease

Cost per unlimited megabit is still more at AT&T, so I'd obviously prefer to get this fixed.  Imagine my surprise when I found that the site had services showing on my address that weren't actually available.

 

I don't know if I mentioned this upthread or not, so I'll say it again - Steam is still downloading at ~35MB/s, while everything else is at 20MB/s.  If the CDN works at full speed, I would think that this indicates that the problem with *everything* else lies way further upstream and that my equipment is OK.

Frequent Visitor

Re: Speed Decrease

I don't want to be "that guy", but when you say backed up do you mean days, or weeks?  Ideally I'd like to get whatever is going on fixed then try the gigabit upgrade, but if I can't I need to move on.

Official Employee

Re: Speed Decrease

Hi mafu, I can assist you with getting your speed issue taken care of. Can you please send me a private message with your full name, street address, and account number by clicking on my name (ComcastAmir) and then "private message me"?

Regular Contributor

Re: Speed Decrease

Can we get an update on this? Very interested in hearing if the problem was resolved, and how, or if the OP has moved back to AT&T or another solution . . .

 

Thanks!

Frequent Visitor

Re: Speed Decrease

Well, the update is that after a ton of equipment swapping, three techs saying that they couldn't figure it out, and more speed tests than I thought possible, I went ahead and upgraded to gigabit with my own MB8600.  The problem remained, only a *little* faster.  Some things were consistently slow, some were fast.

 

I have no idea what ended up fixing it, but two days later someone hit the gas.  Everything is now as it should have been. If I had to guess, there were some lingering Comcast/Cogent issues that got resolved.

 

 

Regular Contributor

Re: Speed Decrease

Thanks for the update. Great that the source of the problem wasn't your equipment or wiring. Unfortunate that you had to go through all of that troubleshooting. But at least now you have gigabit. Smiley Happy

Official Employee

Re: Speed Decrease

 

mafu wrote: Well, the update is that after a ton of equipment swapping, three techs saying that they couldn't figure it out, and more speed tests than I thought possible, I went ahead and upgraded to gigabit with my own MB8600.  The problem remained, only a *little* faster.  Some things were consistently slow, some were fast.

 

I have no idea what ended up fixing it, but two days later someone hit the gas.  Everything is now as it should have been. If I had to guess, there were some lingering Comcast/Cogent issues that got resolved

 

Thank you for updating us on your resolution, have a good day.