Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,760,594

members

43

online now

1,916,609

discussions

Back to Top

Routing issues with Level 3

ANSWERED
New Poster

Routing issues with Level 3

I am having routing issues with Level 3 dropping packets see below. I am unable to get to my dog trainer's website on Xfinity / Comcast network in Minneapolis. However, if I connect through Express VPN I don't have any issues.  So I know the server is up and running and able to serve pages.

 

Trying to figure out what is going on with Level 3 and Comcast.

 

Tracing route to mndogtraining.com [173.205.124.115]
over a maximum of 30 hops:

1 6 ms 3 ms 4 ms testwifi.here [192.168.86.1]
2 11 ms 14 ms 10 ms 96.120.48.57
3 13 ms 14 ms 15 ms po-102-rur01.brooklynpark.mn.minn.comcast.net [68.85.165.177]
4 9 ms 12 ms 10 ms po-2-rur02.brooklynpark.mn.minn.comcast.net [96.108.52.54]
5 13 ms 15 ms 14 ms be-5-ar01.roseville.mn.minn.comcast.net [96.108.52.45]
6 28 ms 10 ms 11 ms 4.68.71.61
7 * * * Request timed out.
8 45 ms 41 ms 41 ms INMOTION-HO.ear3.Washington1.Level3.net [4.79.22.110]
9 * * * Request timed out.
10 * * * Request timed out.
11 39 ms 40 ms 44 ms ecvp103.inmotionhosting.com [198.46.81.98]
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 ^C

 

I cancelled at hop 20 as it just keeps timing out anyway. 

 

Accepted Solution

Re: Routing issues with Level 3


robertdusmn wrote: I contacted the hosting company and they saw nothing on their end that would be blocking me from accessing their server. ...

Hosting companies often respond this way. The systems that block IPs are typically automatic, and unknown to most of the host's staff.

 


... My latest, seems to be the same spots that drop packets. ...

Occasional "request timed out" responses aren't significant as long as the trace completes and you can access the site. I can access mndogtraining.com, even though my trace has gaps:

 


C>tracert -4 mndogtraining.com
Tracing route to mndogtraining.com [173.205.124.115] over a maximum of 30 hops:
   1    <1 ms    <1 ms    <1 ms  router1 [192.168.1.1]
   2      8 ms      7 ms      8 ms  96.120.9.181 [96.120.9.181]
   3      8 ms      8 ms      8 ms  te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
   4    10 ms    10 ms      9 ms  be-50-ar01.lancaster.pa.pitt.comcast.net [162.151.20.33]
   5    18 ms      *          17 ms  be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
   6    17 ms    17 ms    18 ms  4.68.71.133
   7      *            *             *        Request timed out.
   8    26 ms    26 ms    26 ms  INMOTION-HO.ear3.Washington1.Level3.net [4.79.22.110]
   9      *            *             *        Request timed out.
 10      *            *             *        Request timed out.
 11    27 ms    26 ms    26 ms  ecvp103.inmotionhosting.com [198.46.81.98]
 12    24 ms    23 ms    23 ms  173.205.124.115
Trace complete.

As suggested previously, when one customer can reach a site but another cannot, it usually means the site is blocking that customer's public Comcast IP. You need to go back to the site's admins for help with this. You can look up your IP at "https://www.google.com/search?q=IP".

 

The only other thing you can do is change your public IP by changing the MAC address seen by your modem if your equipment setup has that capability (Comcast's gateway devices do not).

View answer in context
Tags (3)
Connection Expert

Re: Routing issues with Level 3

Your packets are beyond Comcast's and Level3's webspace. You make it in to the web host's web space. That is where your WAN / public IP address is being blocked. You need to contact the web host "inmotionhosting.com" about this.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Routing issues with Level 3

I contacted the hosting company and they saw nothing on their end that would be blocking me from accessing their server. The server is functioning but not much they do to help if you aren't a customer trying to get assistance with a product. So I'm on phone with comcast to see their thoughts. Hopefully something can be figured out. They also used https://geopeeker.com/fetch/?url=mndogtraining.com to show the site was up and running. Which I knew since express VPN and at work the site responds.

 

My latest, seems to be the same spots that drop packets.

 

Tracing route to mndogtraining.com [173.205.124.115]
over a maximum of 30 hops:

1 4 ms 3 ms 4 ms testwifi.here [192.168.86.1]
2 13 ms 19 ms 13 ms 96.120.48.57
3 15 ms 12 ms 10 ms po-102-rur01.brooklynpark.mn.minn.comcast.net [68.85.165.177]
4 14 ms 16 ms 13 ms po-2-rur02.brooklynpark.mn.minn.comcast.net [96.108.52.54]
5 12 ms 11 ms 14 ms be-5-ar01.roseville.mn.minn.comcast.net [96.108.52.45]
6 13 ms 15 ms 13 ms 4.68.71.61
7 * * * Request timed out.
8 40 ms 40 ms 38 ms INMOTION-HO.ear3.Washington1.Level3.net [4.79.22.110]
9 * * * Request timed out.
10 * * * Request timed out.
11 40 ms 40 ms 38 ms ecvp103.inmotionhosting.com [198.46.81.98]
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.
30 * * * Request timed out.

Trace complete.

 

Connection Expert

Re: Routing issues with Level 3

The trace doesn't lie. And those hops in the middle of a trace are not "dropped packets". They are routers that are deliberately configured not to respond to ICMP packet based trace and ping probes, hence the timeouts.

 

http://customer.xfinity.com/help-and-support/internet/run-traceroute-command/

 

https://www.nanog.org/meetings/nanog47/presentations/Sunday/RAS_Traceroute_N47_Sun.pdf




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Gold Problem Solver

Re: Routing issues with Level 3


robertdusmn wrote: I contacted the hosting company and they saw nothing on their end that would be blocking me from accessing their server. ...

Hosting companies often respond this way. The systems that block IPs are typically automatic, and unknown to most of the host's staff.

 


... My latest, seems to be the same spots that drop packets. ...

Occasional "request timed out" responses aren't significant as long as the trace completes and you can access the site. I can access mndogtraining.com, even though my trace has gaps:

 


C>tracert -4 mndogtraining.com
Tracing route to mndogtraining.com [173.205.124.115] over a maximum of 30 hops:
   1    <1 ms    <1 ms    <1 ms  router1 [192.168.1.1]
   2      8 ms      7 ms      8 ms  96.120.9.181 [96.120.9.181]
   3      8 ms      8 ms      8 ms  te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
   4    10 ms    10 ms      9 ms  be-50-ar01.lancaster.pa.pitt.comcast.net [162.151.20.33]
   5    18 ms      *          17 ms  be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
   6    17 ms    17 ms    18 ms  4.68.71.133
   7      *            *             *        Request timed out.
   8    26 ms    26 ms    26 ms  INMOTION-HO.ear3.Washington1.Level3.net [4.79.22.110]
   9      *            *             *        Request timed out.
 10      *            *             *        Request timed out.
 11    27 ms    26 ms    26 ms  ecvp103.inmotionhosting.com [198.46.81.98]
 12    24 ms    23 ms    23 ms  173.205.124.115
Trace complete.

As suggested previously, when one customer can reach a site but another cannot, it usually means the site is blocking that customer's public Comcast IP. You need to go back to the site's admins for help with this. You can look up your IP at "https://www.google.com/search?q=IP".

 

The only other thing you can do is change your public IP by changing the MAC address seen by your modem if your equipment setup has that capability (Comcast's gateway devices do not).

Connection Expert

Re: Routing issues with Level 3

Thanks for expanding BruceW !




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Routing issues with Level 3

So if I'm reading correctly, my public Comcast IP address is most likely the issue (something happened then over last few weeks) since the Express VPN service gives me a different public facing IP address and it works. Thank you for the information on the requested time out. I'll go back to Comcast and see what can be done. I'm not sure how to change my public facing Mac Address .... it is the Comcast WiFi modem that they rent to me. I did turn into Bridge Mode and use Google WiFi internally. 

 

I did go to 3 different people at Comcast. The first 2 didn't know what I was talking about. but they got me to a 3rd person who understood what I was having issues with. They said there were going to do something to my modem remotely, but nothing has happened as of yet. Thanks again for everyone's help in reviewing this issue. 

 

 

Gold Problem Solver

Re: Routing issues with Level 3


robertdusmn wrote: ... it is the Comcast WiFi modem that they rent to me. I did turn into Bridge Mode ...

I neglected to consider that you might be operating in bridge mode. Typically that means the Comcast gateway device is connected via an Ethernet cable to a router. Most routers have some sort of "clone MAC" or similar method of changing the MAC address seen by the gateway's modem component. When you alter the router's WAN MAC and then reboot the gateway (still in bridge mode), Comcast's DHCP servers should assign a new public IP address.

New Poster

Re: Routing issues with Level 3

I tried resetting comcast router, turned off bridge mode and still couldn't access the site. I connected direct to the Comcast router / modem with an ethernet cable. Next, I tried connecting to an open xfinitywifi spot and I can get to the website no issue. 

 

I then tried a different modem and that didn't help either. So I've put everything back the way it was, Comast WiFi router/modem in Bridge mode and then connected the Google WiFi devices (which also had been reset) back to the Comcast Modem. 

 

Unfortunately, I don't believe Google WiFi supports Cloning Mac Address at least not from what I'm reading. But not sure that would help anyway if resetting things and trying a different piece of hardware didn't solve the problem. At the end of the day it is one website but I'm going to keep discussing w/ Comcast as I shouldn't have to use a VPN service just to get to that website. Or use an open xfinitywifi hotspot to get there as another option. Quite annoyed to get assigned IP address that is being blocked now...makes me wonder what other sites might get impacted in the future as well. 

 

Thanks again for your help. 

New Poster

Re: Routing issues with Level 3

After sleeping on it and coming back to the whole clone MAC, it was like a snake was in the room and I missed it. I have 3 Google Wifi devices. So I reset them all again. But this time, I replaced the primary one that connects to the modem with the one that had been in the Kitchen. Different MAC address. That did the trick. It forced a new IP address and now I can get to the website. Thank you again for replying and helping me work through this and for everyone that replied actually. MUCH appreciated. 

 

Have a good day

 

 

Highlighted
Gold Problem Solver

Re: Routing issues with Level 3


robertdusmn wrote: ... I replaced the primary one that connects to the modem with the one that had been in the Kitchen. Different MAC address. That did the trick. ...

Excellent! I'm not familiar with Google's WiFi devices and would not have known to do this. Well done!